Thaiadmin

การทำ inter-vlan routing บน Layer 3 switch (cisco)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

Athena_Shield

การทำ inter-vlan routing บน Layer 3 switch (cisco)
« เมื่อ: 19 สิงหาคม 2005, 04:11:05 »

คือว่าท่านสั่งมาให้ทำ VALN 3 วงครับ แต่ผมไม่มีความรู้เรื่อง Switch Cisco เลยครับ�
1. Switch Cisco 2950G-24 จะทำ Vlan 3 วง คือ 192.168.1.xxx/24 , 192.168.2.xxx/24 , 192.168.3.xxx/24
2. Switch จากข้อ 1 มาทำการ Route ที่ Switch Cisco 3350 L3 ครับ

*** รบกวนช่วยอธิบายแบง่าย ๆ หน่อยนะครับ ผมไม่เป็นเลยครับ แต่มีพื้นการ Set Router อยู่บ้างครับ
ขอบคุณล่วงหน้าทุกท่านครับ (ถ้าอธิบายเป็นภาษาไทยได้จะเยี่ยมเลยครับ.... ฮะ ฮะ ภาษาอังกฤษผมไม่ค่อยแข็งแรงครับ)


คำถามจากกระทู้ : http://www.thaiadmin.org/board/index.php?topic=7862.0




*** ต้องขอออกตัวไว้ก่อนนะครับ ว่าผมเองไม่ค่อยถนัดนักในเรื่องของ switch และเนื่องจากที่ lab
ยังไม่มี 3550 ใช้ผมเลยไม่สามารถทดลองจนรู้ผลได้ เลยไม่ชัวร์กับ config ในส่วนของ 3550 นะครับ


สำหรับเครื่องลูกข่าย

  • ตั้ง ip ให้กับ เครื่องลูกข่าย (โดยแยกตามกลุ่ม ip ที่ต้องการ)
  • ตั้งค่า gateway ที่จะใช้ข้ามออกไปยังเครือข่ายอื่น ให้กับเครื่องลูกข่าย

� � �โดยค่านี้ จะต้องอยู่ในกลุ่มเดียวกันกับ ip ของเครื่องลูกข่าย เพราะจะต้อง
� � �เอาไปตั้งให้กับ vlan interface หรือ interface ที่ฝั่งของ L3 เพื่อทำการ routing


สำหรับตัว L2 หรือ 2950

น่าจะมีขั้นตอนหลักๆที่เราต้องทำอยู่ 3-4 อย่างครับ ก็คือ ..

  • สร้าง vtp domain รวมทั้งกำหนด mode และค่าอื่นๆของ vtp domain
  • สร้าง vlan ขึ้นมาก่อน 3 อัน
  • ทำการแบ่ง port ต่างๆให้เป็นสมาชิกของแต่ละ vlan / และกำหนด mode�
  • กำหนด port ที่จะเป็น trunk ไปยัง L3
  • กำหนดให้ trunk นั้นทำการ allow traffic ของ vlan อื่นๆ

** 2950 ไม่ต้องกำหนด encapsulation ให้กับ trunk port เพราะว่า
มี default เป็น 802.1q อัตโนมัตอยู่แล้วครับ


สำหรับส่วนของ L3

ถ้าคุณจะทำ intervlan routing แบบ trunk เข้ามาที่ L3 แค่เส้นเดียว ...

  • กำหนด encapsulation ให้กับ interface ที่เชื่อมต่อกับ L2 ให้เป็น dot1q
  • ทำ interface vlan ขึ้นมาที่� L3 โดยสร้างตาม vlan ที่อยู่ที่ L2
  • ทำการตั้ง ip ให้กับ interface vlan นั้นๆ เพื่อใช้เป็น gateway ของเครื่องลูกข่ายใน vlan นั้น


แต่ถ้าคุณจะทำการ route โดยใช้สายแบบ vlan ละ 1 เส้น ก็สามารถนำไปต่อกับ L3 ได้เลย
แล้วก็แค่ตั้ง ip ให้กับ interface ที่คุณไปต่อด้วยเท่านั้นเองครับ โดยให้ ip เป็น ip ในกลุ่ม
เดียวกันกับเครื่องลูกข่าย ที่เป็นสมาชิกของ vlan นั้นๆ และใช้ ip ของ interface นี้เป็น
ให้เป็น gateway ของเครื่องลูกข่ายของ vlan นั้นๆก็ได้แล้วครับ ...


*** ส่วนเรื่อง vtp นั้นเนื่องจากข้างบนไม่ได้ระบุไว้ว่ามี L2 switch กี่ตัว และมีโครงสร้าง
อะไรยังไงบ้าง ก็เลยขอข้ามส่วนนี้ไปก่อนก็แล้วกันนะครับ

----------------------------------------------------------------------------------------------------------------------

ถ้าแบบคร่าวๆ ก็น่าจะประมาณนี้นะครับ .......

แหะๆ ปล่อยไก่อีกแน่ๆเลยผม เวลาเขียนไรยาวๆแบบนี้ ขออภัยไว้ล่วงหน้าเลยนะฮะ ^_^

การตั้ง VLAN ....

Switch>
Switch>en
Switch#config t
Switch(config)#vlan 10� �<<---- หมายเลขพวกนี้คือ vlan-id
Switch(config-vlan)#^Z
Switch#

*** ถ้าไม่มีการตั้งชื่อแล้ว VLAN 10� จะมีชื่อเป็น VLAN0010�
� � �การตั้งชื่อทำได้โดยใช้คำสั่ง name แล้วตามด้วยชื่อที่ต้องการ�
� � �เช่น Switch(config-vlan)# name depart1

----------------------------------------------------------------------------------------------------------------------

การกำหนดสมาชิกให้กับ VLAN ที่สร้างขึ้น

Switch>
Switch>en
Switch#config t
Switch(config)#int f0/7 � � <--- int แล้วตามด้วย port
Switch(config-if)#switchport mode access� �<<---- กำหนด mode ของ port ให้เป็น access
Switch(config-if)#switchport access vlan 10 <<---- ระบุ vlan-id
Switch(config-if)#^Z
Switch#

*** ปรกติ port ต่างๆ จะอยู่ใน VLAN 1 เป็น default อยู่แล้ว ...


----------------------------------------------------------------------------------------------------------------------

การทำ trunking port.

Switch>
Switch>en
Switch#config t
Switch(config)#int f0/12
Switch(config-if)#switchport mode trunk� <<---- กำหนด mode ของ port ให้เป็น Trunk
Switch(config-if)#switchport trunk allowed vlan all� <<---- ถ้าไม่ใช้ all ก็ระบุ vlan-id ที่ต้องการลงไป
Switch(config-if)#^Z
Switch#

**** เป็นการกำหนดให้ port นั้น เป็น trunk port ... แต่ไม่ต้องกำหนด trunk encapsulatoin dot1q
� � � เพราะว่า 2950 ใช้ได้แต่ 802.1q เท่านั้นฮะ แต่ผมเคยเห็น config ของ gigabit port เค้าจะ
� � �สามารถใช้คำสั่ง switchport trunk encapsulation dot1q� ได้เหมือนกันนะฮะ

----------------------------------------------------------------------------------------------------------------------

การเปิดการทำงานด้าน routing� บน L3

Switch(config)#ip routing� <<---- สั่งให้ L3 ทำงานด้าน routing


การทำ trunking port บน L3

Switch(config)#int f0/1� �<<---- interface ที่ต่อกับ trunk ของ L2
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#....� <<--- หากต้องการเพิ่มเติมคำสั่งอะไรก็ใส่ลงไปได้ เช่นเรื่องของ EtherChannel , Trunk
Switch(config-if)#^Z

การทำ Vlan Interface บน L3

Switch(config)# interface vlan 10� <<---- vlan <vlan-id>
Switch(config-if)#ip address <ip address> <subnet mask> <<----� ใช้เป็น default gateway ของสมาชิกใน vlan นั้น
Switch(config-if)#no shutdown


ถ้าเราสร้าง vlan interface� และได้ทำการตั้ง ip ให้กับแต่ละ vlan interface เรียบร้อยแล้ว
interface เหล่านี้ ก็จะมีสถานะใน routing table เป็น directly connect โดยอัตโนมัต ดังนั้น
เราไม่ต้องมาทำ routing ในส่วนนี้อีกครับ



ข้อมูลข้างบนนี้ เขียนจากเท่าที่พอจานึกออก และ เอกสารของ cisco และกระทู้เก่าๆที่เคยตอบไว้นะฮะ
อาจจะไม่ค่อยละเอียด หรือไม่ค่อยถูกต้องตามที่ต้องการนัก แต่คาดว่าน่าจาพอใช้ได้บ้าง� ... ^_^


ตัวอย่างของการ config

สอบถามการ SET VLAN Switch L2 กับ L3 ครับ
http://www.thaiadmin.org/board/index.php?topic=7862.msg41792#msg41792


ข้อมูลเพิ่มเติม

� � Command Reference

� � Catalyst 3550 Multilayer Switch Command Reference
� � http://www.cisco.com/en/US/products/hw/switches/ps646/products_command_reference_chapter09186a0080475f11.html

� � Catalyst 2950 and Catalyst 2955 Switch Command Reference
� � http://www.cisco.com/en/US/products/hw/switches/ps628/products_command_reference_chapter09186a00804761fd.html


� � Case Study / Example

� � How To Configure InterVLAN Routing on Layer 3 Switches
� � http://www.cisco.com/warp/public/473/howto_L3_intervlanrouting.html

� � Configuring Inter-VLAN Routing with Catalyst 3750 Series Switches
� � http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a00801cc828.shtml

� � Configuring InterVLAN Routing and ISL/802.1Q Trunking on Catalyst 2900XL/3500XL/2940/2950
� � http://www.cisco.com/warp/public/473/50.shtml




ปล.เนื่องด้วยผม ไม่สามารถทดสอบ config ในส่วนของ L3 ได้ เพราะติดขัดด้านอุปกรณ์�
ถ้าตัวอย่างหรือข้อมูลที่ลงไว้ข้างบนนี้มีข้อผิดพลาดประการใด ผมก็ต้องขออภัยด้วยนะครับ ... ^_^
« แก้ไขครั้งสุดท้าย: 6 กรกฎาคม 2006, 20:06:38 โดย Athena Shield »

Athena_Shield

การทำ inter-vlan routing บน router 2600 (cisco)
« ตอบกลับ #1 เมื่อ: 19 สิงหาคม 2005, 04:57:47 »
� �


config สำหรับส่วนของ router ...

ส่วนของ Layer 2 Switch และ Client ยังคงเหมือนกับของอันบนนะครับ..

เผื่อเอาไว้สำหรับคนที่จำทำ route จาก L2 (2950) มายัง router� ...
เป็นกรณีที่คุณจะทำ intervlan routing แบบ trunk เข้ามาที่ router เป็น trunk แค่เส้นเดียว ...


  • ทำ sub interface ที่ interface ของ router ที่คุณต้องการ
  • กำหนด encapsulation ให้กับแต่ละ sub interface ให้เป็น dot1q
  • กำหนด ip ให้กับ แต่ละ sub interface (ใช้ ip ของ gateway ที่ตั้งให้ลูกข่ายมาตั้ง)


แต่ถ้าคุณจะทำการ route โดยใช้สายแบบ vlan ละ 1 เส้น ก็สามารถนำไปต่อกับ router ได้เลย
แล้วก็แค่ตั้ง ip ให้กับ interface ที่คุณไปต่อด้วยเท่านั้นเองครับ โดยให้ ip เป็น ip ในกลุ่มเดียวกัน
กับเครื่องลูกข่าย ที่เป็นสมาชิกของ vlan นั้นๆ และใช้ ip ของ interface นี้เป็นให้เป็น gateway
ของเครื่องลูกข่ายของ vlan นั้นๆก็ได้แล้วครับ ...


----------------------------------------------------------------------------------------------------------------------

การทำ Inter-vlan routing� บน Router 2600 .....

Inter-vlan� routing ควรทำกับ port ที่เป็น FastEthernet ขึ้นไปครับ .....

รูปแบบคำสั่ง ....

R2600(config)#int f0/0.1 <<---------- เป็นการทำ sub interface
R2600(config-subif)#encapsulation dot1q� vlan <vlan-id>� << ----- กำหนดหมายเลข vlan ลงไป
R2600(config-subif)#ip address <ip address> <subnetmask>� �<<----- ใช้ ip นี้เป็น Gateway

เช่น ...


Router#config t
Router(config)#int f0/0� �<<---- interface หลัก
Router(config-if)#no ip address � <--- ไม่ให้ interface นี้มี ip
Router(config-if)#no shutdown� �<---- ไม่ให้ทำการ shutdown interface นี้
.....
Router(config-if)#int f0/0.1� <<---- sub interface 0.1
Router(config-subif)#encapsulation dot1q 10 � �
Router(config-subif)#ip address 10.1.1.2� 255.255.240.0
.....
Router(config-if)#int f0/0.2� <<---- sub interface 0.2
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 192.200.200.2 255.255.255.0


ip ใดๆก็ตาม ที่ถูกตั้งให้ Interface หรือ sub interface ของ router นั้น
จะเป็น direct connect อัตโนมัตอยู่แล้ว โดยไม่ต้องทำ route ฮะ


ข้อมูลเพิ่มเติม

การทำ Routing บนVlan
http://www.thaiadmin.org/board/index.php?topic=7399.0





ปล.ถ้าตัวอย่าง หรือข้อมูลที่ลงในส่วนต่างๆของกระทู้นี้ มีข้อผิดพลาด หรือบกพร่องอะไปก็ขออภัยไว้ด้วยนะครับ ^_^
« แก้ไขครั้งสุดท้าย: 30 มีนาคม 2006, 13:45:04 โดย Aegis In The Dark. »

Athena_Shield

� �
ข้อมูลเพิ่มเติม

Command Reference

� � � Catalyst 3550 Multilayer Switch Command Reference
� � � http://www.cisco.com/en/US/products/hw/switches/ps646/products_command_reference_chapter09186a0080475f11.html

� � � Catalyst 2950 and Catalyst 2955 Switch Command Reference
� � � http://www.cisco.com/en/US/products/hw/switches/ps628/products_command_reference_chapter09186a00804761fd.html


� � � � � � � � � � � � � � � � � � � � � � � � � � � � � �..............................................................................

Basic Concept & Config

� � � ชนิดของ vlan (คำอธิบาย)
� � � http://www.thaiadmin.org/board/index.php?topic=9930.msg51010#msg51010

� � � Configuring Layer 2 Ethernet Interfaces
� � � http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/12_1_11/config/layer2.htm

� � � Catalyst 2950 Switch Software Configuration Guide - Configuring VLANs
� � � http://www.cisco.com/en/US/products/hw/switches/ps628/products_configuration_guide_chapter09186a00801a6bb5.html

� � � Catalyst 2950 Switch Software Configuration Guide - Configuring VTP
� � � http://www.cisco.com/en/US/products/hw/switches/ps628/products_configuration_guide_chapter09186a00801a6bb6.html

� � � Catalyst 2950 Switch Software Configuration Guide - Configuring EtherChannels� (เผื่อไว้)
� � � http://www.cisco.com/en/US/products/hw/switches/ps628/products_configuration_guide_chapter09186a00801a6b97.html

� � � ข้อมูลเกี่ยวกับการทำ encapsulation แบบต่างๆ (cisco)
� � � http://www.thaiadmin.org/board/index.php?topic=7460.0


� � � � � � � � � � � � � � � � � � � � � � � � � � � � � �..............................................................................

Case Study / Example

� � � Configuring Inter-VLAN Routing with Catalyst 3750 Series Switches
� � � http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a00801cc828.shtml

� � � Configuring InterVLAN Routing and ISL/802.1Q Trunking on Catalyst 2900XL/3500XL/2940/2950
� � � http://www.cisco.com/warp/public/473/50.shtml

� � � Configuring Layer 2 EtherChannel and Trunking Between 2950 Series (เผื่อไว้)
� � � http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a0080094bc5.shtml


� � � � � � � � � � � � � � � � � � � � � � � � � � � � � �..............................................................................

เคสที่น่าสนใจ จากบอร์ดของ thaiadmin

� � � การทำ Routing บนVlan
� � � http://www.thaiadmin.org/board/index.php?topic=7399.0

� � � ช่วยหน่อยครับ เรื่อง VLAN บน 3com 4900 ,3300 (ช่วยชีวิตผมด้วย)
� � � http://www.thaiadmin.org/board/index.php?topic=6223.0

� � � ช่วยแนะนำวิธีการ config route ที่ตัว switch 3com 4900 หน่อยค่ะ
� � � http://www.thaiadmin.org/board/index.php?topic=6198.0

� � � มีใครใช้ D-Link DES-6500 บางครับช่วยผมหน่อย
� � � http://www.thaiadmin.org/board/index.php?topic=6058.0

� � � Cisco 3548 อยากได้ speed มากกว่า 100 Mbps
� � � http://www.thaiadmin.org/board/index.php?topic=6899.0


« แก้ไขครั้งสุดท้าย: 25 กันยายน 2005, 18:49:36 โดย Aegis In The Dark. »