Thaiadmin

ลง appserv แล้วเข้าที่ localhost หรือ (127.0.01) ไม่ได้ครับ (ยากจริง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

pyayam

ลง appserv แล้วเข้าที่ localhost หรือ (127.0.01)  ไม่ได้ครับ แนะนำหน่อยครับ

คือ ผมเขียนระบบ PHP+MYSQL ระบบรับสมัครงานของ บ.แห่งหนึ่ง ของไทย
พอทดสอบระบบที่เครื่องผมทุกอย่างก็ ok 
พอ test ที่ office หรือที่เครืองอื่น ๆ ก็ได้


แต่ว่าพอไปลงที่ บ.ของลูกค้า ( ผมเข้าไปที่ localhost ไม่ได้) ทั้ง ๆ ที่ลง appserv ได้สมบูรณ์
service ของ apache ก็เปิดใช้งานเรียบร้อยแล้ว


โดยเครื่องที่ผมติดตั้งคือเครื่อง server
ผม run จาก server ก็เข้า localhost ไม่ได้


ตรงเครื่องลูกข่ายผมไม่แน่ใจว่าผมเข้าถูก ไหม (แนะนำการเข้าให้ผมด้วยนะครับ หากว่าผมเข้าผิด)
และมาลอง เข้าที่เครื่องลูกค้าข่าย โดยลองเข้าแบบ ip ของเครื่อง server:8080/path ของระบบที่เขียน

**โดย ip นั้นผม check โดยการเข้าที่ run พิมพ์ว่า cmd และพิมพ์ ipconfig


หมายเหตุ
1. ผมได้ลอง restart และเข้าที่ localhost ก็เข้าไม่ได้ครับ
2. เครื่องนั้นไม่ได้มีการติดตั้ง IIS ไว้ในก่อนหน้านี้


ช่วยแนะนำหน่อยนะครับ ว่าอาจจะเกิดจากสาเหตุอะไรได้บ้างครับ

ออฟไลน์ eth0

  • *
  • 810
  • 10
  • เพศ: ชาย
โดย default ของ apache ของ appserv มัน listen ที่ port 80 นี่ครับ ทำไมถึงเรียก เข้า แบบนั้นล่ะครับ(server:8080/path )
ลอง server/path ดุก่อนสิครับ อ้อ แล้ว server ต้องปลด firewall ให้สามารถ เข้า มาใช้บริการ ด้วยนะครับ (ถ้าจะเรียกจาก เครื่องอื่นในเครือข่าย)
ดังรูปครับ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย