Thaiadmin

ติดตั้ง phpmyadmin ไม่ได้ครับ

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ติดตั้ง phpmyadmin ไม่ได้ครับ
« เมื่อ: 21 สิงหาคม 2015, 23:14:57 »
E: Package 'phpmyadmin' has no installation candidate

ออฟไลน์ Keigo

  • *****
  • 1,845
  • 29
  • เพศ: ชาย
  • TH@min Membership
Re: ติดตั้ง phpmyadmin ไม่ได้ครับ
« ตอบกลับ #1 เมื่อ: 22 สิงหาคม 2015, 00:59:37 »
ใช้ Linux distribution อะไร version อะไรครับ? Debian/Ubuntu apt-get install ได้เลย, RHEL/CentOS ลงผ่าน EPEL, SUSE ใช้ yast หรือ zypper ได้เลยจ้า
<b>When we wake up in the morning, we have two simple choices. Go back to sleep and dream, or wake up and chase those dreams.</b>

Re: ติดตั้ง phpmyadmin ไม่ได้ครับ
« ตอบกลับ #2 เมื่อ: 22 สิงหาคม 2015, 07:53:13 »
ผมลองแล้วครับ   sudo apt-get  install  phpmyadmin

Re: ติดตั้ง phpmyadmin ไม่ได้ครับ
« ตอบกลับ #3 เมื่อ: 22 สิงหาคม 2015, 07:55:07 »
ผมลองแล้วครับ   sudo apt-get  install  phpmyadmin มันขึ่นแบบนี่ E: Package 'phpmyadmin' has no installation candidate ครับ

ออฟไลน์ Keigo

  • *****
  • 1,845
  • 29
  • เพศ: ชาย
  • TH@min Membership
Re: ติดตั้ง phpmyadmin ไม่ได้ครับ
« ตอบกลับ #4 เมื่อ: 22 สิงหาคม 2015, 15:45:06 »
ใช้ Debian/Ubuntu version อะไรครับ?
<b>When we wake up in the morning, we have two simple choices. Go back to sleep and dream, or wake up and chase those dreams.</b>

Re: ติดตั้ง phpmyadmin ไม่ได้ครับ
« ตอบกลับ #5 เมื่อ: 22 สิงหาคม 2015, 19:29:25 »
 ubuntu-12.04.3-server-amd64.iso

ออฟไลน์ stwatchai

  • *****
  • 3,917
  • 4
  • เพศ: ชาย
  • System & Network Administrator
Re: ติดตั้ง phpmyadmin ไม่ได้ครับ
« ตอบกลับ #6 เมื่อ: 22 สิงหาคม 2015, 21:11:23 »
ได้ทำต่อไปนี้หรือยังครับ
apt-get -y update
apt-get -y upgrade
apt-cache search phpmyadmin

ครับ

Re: ติดตั้ง phpmyadmin ไม่ได้ครับ
« ตอบกลับ #7 เมื่อ: 22 สิงหาคม 2015, 21:28:30 »
ทำแล้วก็ขึ้นเหมือนเดิมครับ

Re: ติดตั้ง phpmyadmin ไม่ได้ครับ
« ตอบกลับ #8 เมื่อ: 22 สิงหาคม 2015, 21:30:27 »
E: Package 'phpmyadmin' has no installation candidate ครับ

ออฟไลน์ stwatchai

  • *****
  • 3,917
  • 4
  • เพศ: ชาย
  • System & Network Administrator
Re: ติดตั้ง phpmyadmin ไม่ได้ครับ
« ตอบกลับ #9 เมื่อ: 22 สิงหาคม 2015, 21:49:42 »
ไม่แน่ใจว่ามี error อะไรหรือเปล่าครับ หลังจากสั่งแต่ละบรรทัด
apt-get -y update (มี error หรือเปล่าครับ)
apt-get -y upgrade (มี error หรือเปล่าครับ)
apt-cache search phpmyadmin ค้นหาเจอหรือไม่ครับ

ออฟไลน์ Keigo

  • *****
  • 1,845
  • 29
  • เพศ: ชาย
  • TH@min Membership
Re: ติดตั้ง phpmyadmin ไม่ได้ครับ
« ตอบกลับ #10 เมื่อ: 23 สิงหาคม 2015, 21:57:20 »
คิดว่าคุณน่าจะติดปัญหา Hash Sum mismatch ตอน apt-get update

วิธีแก้คือเข้าไปบลบ archive package list ตาม path นั้นๆ ยกตัวอย่างเช่น ผมติดตรงที่
W: Failed to fetch bzip2:/var/lib/apt/lists/partial/no.archive.ubuntu.com_ubuntu_dists_precise_main_source_Sources  Hash Sum mismatch

ผมก็เข้าลบ
$ sudo rm /var/lib/apt/lists/partial/no.archive.ubuntu.com_ubuntu_dists_precise*
$ sudo rm /var/lib/apt/lists/no.archive.ubuntu.com_ubuntu_dists_precise*

จากนั้นค่อย apt-get update แล้ว install ต่อ
$ sudo apt-get update
$ sudo apt-get install phpmyadmin

<b>When we wake up in the morning, we have two simple choices. Go back to sleep and dream, or wake up and chase those dreams.</b>