Thaiadmin

ลง Firebrid ใน centos 7 แล้ว error ครับ

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ลง Firebrid ใน centos 7 แล้ว error ครับ
« เมื่อ: 28 มีนาคม 2015, 14:50:55 »
ลง Firebrid ใน centos 7 แล้ว error  ครับ
คำสั่ง

  root #rpm -ivh FirebirdCS-2.5.3.26780-0.i686.rpm  แล้ว เกิด error ว่า
  Error : Failed dependencies:
             libncurses.so.5 is needed by FirebirdCS-2.5.3.26780-0.i686
             libstdc++.so.6 is needed by FirebirdCS-2.5.3.26780-0.i686

แบบนี้ครับ ไม่ทราบว่า จะต้องแก้ใขอย่างไร หรือ ว่า error  เกิด จากอะไร ครับ
ช่วยหน่อย นะครับ ผมติดมาหลายวันแล้วววววววววว


ขอบคุณมากๆ ครับ

ออฟไลน์ ~::=::ENTER::=::~

  • *****
  • 788
  • 7
  • เพศ: ชาย
  • :=)(แอดมึน)(= : warnning every time.|||||
    • ข่าวไอที
Re: ลง Firebrid ใน centos 7 แล้ว error ครับ
« ตอบกลับ #1 เมื่อ: 28 มีนาคม 2015, 15:41:08 »
ผมไม่เคยใช้ ไม่เคยติดตั้งนะ แต่เหมือนมันบอกว่าต้องการ  libncurses.so.5 กับ  libstdc++.so.6 สองตัวนี้มั๊งครับ
เดินทางกันต่อไป

ออฟไลน์ nunfather2

  • *
  • 91
  • 0
  • ...ชีวิตมีวันสิ้น คนไม่มีวันพอ...
Re: ลง Firebrid ใน centos 7 แล้ว error ครับ
« ตอบกลับ #2 เมื่อ: 28 มีนาคม 2015, 20:38:48 »
yum install firebird



 ;) น่าจะง่ายสุดแล้วนะครับ มันขาดอะไรเดี๋ยวมันก็ดาวน์โหลดมาให้เองแหละครับ

------------------------------------------------------------------------------------------------------------------------------------------------

 :'( Oh ขอโทษที
ผมลองกับ Fedora มันให้ ยำ แต่กับ CentOS7 มันไม่มี  package firebird

ถ้าอยากลองให้ไปทดสอบกับ Fedora นะครับ เพราะมันยังไม่ฮิตหรือยังไม่... มั๊งเค้าเลยไม่มีให้ใน CentOS7

-----------------------------------------------------------------------------------------------------------------------------------------------

และอีกอย่างนะครับ ก็ถ้าจะลง  libncurses.so.5

ก็แค่ yum -y install libstdc libncurses.so.5

ก็จะดาวน์โหลดทั้ง       libncurses.so.5          libstdc++.so.6  มาให้เองล่ะครับ

แต่มันก็ติดตรงนี้อีกล่ะครับคือ CentO7 เค้าไปเป็น  3.10.0 ซะแล้ว

อ้างถึง
IMPORTANT: Note affecting all Linux builds
The recommended Linux kernel version is 2.6.34 and glibc should be version 2.12 or higher. Minimum - kernel 2.6.27 and glibc 2.7.
If your glibc version is lower than v.2.7, it must be upgraded before using Firebird 2.5 Classic/Superсlassic.

« แก้ไขครั้งสุดท้าย: 30 มีนาคม 2015, 08:17:37 โดย nunfather2 »