Thaiadmin

ช่วยดูหน่อยคะ ระบบที่โรงเรียน ล่มเป็นเวลา ช่วยหาสาเหตุทีคะ

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ตอนนี้ที่โรงเรียน ใช้งานอินเตอร์เนต ผ่าน เซิฟเวอ ที่ คนที่จะใช้งานอินเตอร์เนตทุกคน ต้อง ใส่ ยูสเซอเนม  พาสเวิด ก่อนที่จะเข้าใช้งานอินเตอร์เนตคะ

ใช้มาแรกๆไม่มีปัญหาอะไร ปัญหาเพิ่งมาเกิดเมื่ออาทิตย์ก่อนคะ  คือ เมื่อ ถึงเวลา 10.00 อินเตอร์เนต(ที่ผ่านการออเทน) จะดาวน์คะ ลองปิงเกทเวย์ดู ในแต่ละวัน

ตั้งแต่เช้า ก็จะปกติ พอใกล้ๆ เวลา สิบโมง เกทเวย์ที่ปิง จะ เริ่ม Time out หรือ ไม่งั้นก็  >10 แล้วก็จะเป็นแบบนี้ไปจนถึง บ่ายสามโมงเลยคะ

อธิบายการ เชื่อมต่อ ของอุปกรณ์ ต่างๆดังนี้นะคะ 

ISP --> Router --> Server (authen) --> Hub --> Switch (จ่ายอินเตอร์เนตให้ห้อง,ตึกต่างๆในโรงเรียน) --> Hub --> Clients

ช่วงเวลาที่เนต ดาวน์ ลองเอาโน๊ตบุคมาต่อที่ฮับ หลังเซิฟเวอ (โดยที่ไม่เสียบสายสวิทท์) ก็ใช้งานได้ปกติดีคะ  แต่ถ้าเมื่อไหร่ที่เสียบสายสวิทท์ เข้ามาที่ฮับ

เนตก็จะดาวน์คะ

ที่ งง ก็คือ มันเป็นเฉพาะช่วงเวลานี้เท่านั้นคะ

รบกวนช่วยชี้แนะด้วยค่ะ ใครเคยเจอประสบการณ์นี้ ช่วยแชร์ความรู้หน่อยคะ

ไล่แก้ปัญหาจนไม่รู้จะแก้ทางไหนแล้วคะ ขอบคุณคะ

ออฟไลน์ IT_YooT

  • **
  • 101
  • 0
จากประสบการณ์ของผมนะครับ

เมื่อถึงเวลาเดียวกันในแต่ละวัน Client ที่อยู่บน Switch นั้นๆ

Network จะล่มทั้งหมด Ping หา Gateway ไม่เจอ เป็นสักระยะหนึ่ง

แล้วจะกลับมาใช้ได้ปกติเอง ตอนนั้นผมลองทำหลายทาง ปวดหัวมากๆ

สุดท้ายนะครับ ผมใช้วิธีการไล่เช็คทีละเครื่องที่อยู่บน Switch ตัวนั้น

เมื่อใกล้ถึงเวลาที่ Network หลุด ให้ถอดสาย LAN ออกให้หมด เอา Notebook ตัวเอง

ต่อ Console กับ Switch แล้ว Ping ไปที่ Gateway ค้างไว้

จากนั้นค่อยๆ ไล่เสียบทีละพอร์ตทิ้งช่วงห่างกันสัก 2 นาที

แล้วเสียบพอร์ตต่อๆ ไป จนผมไปเจอพอร์ตนึงที่เสียบแล้วทำให้ Network time out

เพื่อความแน่ใจลองถอดพอร์ตนั้นออก Reboot switch แล้วเสียบใหม่ก็เป็นเหมือนเดิม

ทีนี้ผมก็ไล่ไปจนถึงเครื่องที่ต่อกับพอร์ต LAN นั้น ทำการ Format ซะ ทุกวันนี้ไม่พบอาการนี้อีกเลย

สรุปว่าเคสผมปัญหาเกิดจากไวรัสของ Client เครื่องนั้น ทั้งๆ ที่มี Antivirus แต่เหมือนกับว่า OS มันรวนไปแล้วครับ

วิธีนี้อาจใช้เวลานานหน่อย เอาไว้เป็นวิธีสุดท้ายก็ได้นะครับ

เผื่อว่าจะมีพี่ๆ ท่านอีกแนะนำวิธีที่ดีกว่า ถ้าไม่เข้าใจ Add mail ผม คุยใน MSN ก็ได้ครับ

ka_say at hotmail.com

สู้ๆ ครับ  O0

ขอบคุณที่แชร์ประสบการณ์คะ ตอนนี้ ขออัพเดทอาการเพิ่ม นะคะ

คือ เวลา เน็ต ตัดเนี่ย ที่คอมเครื่องไคลเอนท์ จะโชว์ Network Cable is Unplug แล้วก็ต่อเองคะ ทั้งๆที่ไม่ได้ถอดสาย ไม่ได้ไปยุ่งอะไรกับ ฮาร์ดแวร์เลย - -*

เนตก็ยังคงตัดเวลาเดิมทุกวัน ไม่ว่า ยูสเซอที่ล้อกอินเข้าใช้ จะมากหรือน้อย ตอนเที่ยง ใช้ได้ พอบ่ายปุ๊บ ก็ ดาวน์ เลยคะ

ขอบคุณที่เสนอให้ลองไล่สายดูนะคะ แต่ สายที่ต่อออกจากสวิทท์ มันไปกับ รางสายไฟ ไปแต่ละตึกเลยคะ - -" ลำบากน่าดูถ้าไปรื้อ ยิ่ง
วิศวกร เป็น ชาวไต้หวันอีกด้วยคะ คุยกันไม่รู้เรื่องเลย

chaiyahhhh

ขอบคุณที่เสนอให้ลองไล่สายดูนะคะ แต่ สายที่ต่อออกจากสวิทท์ มันไปกับ รางสายไฟ ไปแต่ละตึกเลยคะ - -" ลำบากน่าดูถ้าไปรื้อ ยิ่ง
วิศวกร เป็น ชาวไต้หวันอีกด้วยคะ คุยกันไม่รู้เรื่องเลย
ผมคิดว่าเขาไม่ได้หมายความว่าเปิดฝารางไฟแล้วไล่สาย
คงจะว่า port นี้ (หมายเลขเบอร์สายนี้) สายเชื่อมต่อไปยังเครื่อง Client หรือ Workstation ไหน
ให้ดูจากหมายเลขสาย ต้นและปลายสาย (marker) หรือดูจาก Wire Diagram ก็ได้ ปลดหมดแล้วค่อยทะยอยเชื่อมต่อรอดูอาการ
***
ใช้ซอฟต์แวร์จับ Traffic หรือ Package ต้องสงสัย หรือมีความผิดปกติ ว่ามันมาจากไหน (ค่อนข้างดูง่าย บอกหมายเลข IP ฯ)
หรือใช้เครื่องมือที่เป็น Hardware   เช่นยี่ห้อ Fuke ราคา 3-5 แสนบาทซึ่งค่อนข้างแพง (จะวิเคราะห์ปัญหาได้หมด พิมพ์รายงานได้) จ้างเขาดีกว่า
คงไม่ค่อยมีใครซื้อมาใช้มั๊งยกเว้นงานรับเหมา หรืองานบริการ หรือบริษัทรับงานด้าน Network คงจะมี

ออฟไลน์ nuaythebest

  • *
  • 94
  • 0
  • CCIE #34465
อาการเหมือน Switch ถูก Flood ทำให้ใช้งานไม่ได้นะครับ ถ้าเป็นไปได้ลองหาพวก Sniifer มาจับดูผ่าน Wireshark ผมว่าน่าจะเห็นอะไรแปลกๆ
CCIE = Know what you don't know

อาการเหมือน Switch ถูก Flood ทำให้ใช้งานไม่ได้นะครับ ถ้าเป็นไปได้ลองหาพวก Sniifer มาจับดูผ่าน Wireshark ผมว่าน่าจะเห็นอะไรแปลกๆ

พอมีโปรแกรมแนะนำไหมคะ  ขอบคุณคะที่ช่วยสันนิษฐาน ความเป็นไปได้ ตอนนี้ สงสัยที่ switch เหมือนกันคะ

ออฟไลน์ denla

  • ***
  • 390
  • 0
  • สะสมประสบการณ์
ลองวิธีผมเบื้องต้นดูนะครับ ลองไปที่เครื่อง client ปิดโปรแกรมให้หมดนะครับ แล้วลอง netstat -an ที่แต่ละเครื่องเลยครับดูว่ามียิง port เยอะๆ ที่เครื่องไหนก็สันนิฐานได้เลยครับว่าเครื่องนั้น

พอดีบริษัทผมก็เคยเป็น แต่ยังดีของผมมีไฟวอลดูว่าเครื่องไหนยิงมาเลยพอดูคร่าวๆได้ครับ
<b>กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย</b>

ออฟไลน์ numit

  • *****
  • 32
  • 0
ลองทำอย่างนี้ดูน่ะครับ ถอดสายแลนที่เชื่อมต่อไป switch hub ของแต่ตัวอาคารออก แล้วไล่เช็คทีละเครื่องหรือทีล่ะอาคาร เพราะคงเกิดจากเครื่อง client มากกว่าครับ (fix ip ชนกันก็มีส่วนทำให้ล่วงได้น่ะครับ)

ออฟไลน์ IT_YooT

  • **
  • 101
  • 0
ขอบคุณที่แชร์ประสบการณ์คะ ตอนนี้ ขออัพเดทอาการเพิ่ม นะคะ

คือ เวลา เน็ต ตัดเนี่ย ที่คอมเครื่องไคลเอนท์ จะโชว์ Network Cable is Unplug แล้วก็ต่อเองคะ ทั้งๆที่ไม่ได้ถอดสาย ไม่ได้ไปยุ่งอะไรกับ ฮาร์ดแวร์เลย - -*

เนตก็ยังคงตัดเวลาเดิมทุกวัน ไม่ว่า ยูสเซอที่ล้อกอินเข้าใช้ จะมากหรือน้อย ตอนเที่ยง ใช้ได้ พอบ่ายปุ๊บ ก็ ดาวน์ เลยคะ

ขอบคุณที่เสนอให้ลองไล่สายดูนะคะ แต่ สายที่ต่อออกจากสวิทท์ มันไปกับ รางสายไฟ ไปแต่ละตึกเลยคะ - -" ลำบากน่าดูถ้าไปรื้อ ยิ่ง
วิศวกร เป็น ชาวไต้หวันอีกด้วยคะ คุยกันไม่รู้เรื่องเลย
ไม่ต้องถึงกับรื้อรางนะครับ คือใช้พวกเครื่อง Test สายต่อหัวท้ายก็ได้ หรือถ้าทำ Wire marker ไว้ก็ดูง่ายเลย

แต่อาการที่อัพเดทล่าสุดเนี่ย เหมือน IP ชนเลยนะครับ ไม่ทราบเครื่องเป็นแบบ Static หรือ Optain ครับ

ถ้ามี Switch สำรองไว้ ผมวคิดว่าลองเปลี่ยนแล้วรอดูอาการไปสักพักก่อนก็ได้ครับ