Thaiadmin

บริษัทจะทำ DHCP แจก IP แต่เครื่องมีประมาณ 400 เครื่องควรจะออกแบบยังไงครับ

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ออฟไลน์ m_heart_mylove

  • *****
  • 33
  • 0
  • TH@min Membership
บริษัทจะทำ DHCP แจก IP แต่เครื่องมีประมาณ 400 เครื่องควรจะออกแบบยังไงครับ
เพราะตอนนี้ที่ใช้ IP อยู่แยกเป็น 2 วงครับคือ 192.168.0.1 และ 192.168.1.1
ควรจะทำยังไงครับ
ขอบคุณครับ  :( :(
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ เด็กด้อยโอกาส

  • *****
  • 186
  • 0
  • เพศ: ชาย
  • เด็กน้อย ด้อยโอกาส
    • http://www.diamondaccounting-boi.com/
ผมว่า น่าจาทำแยกสัก 3 วง นะ 2 วงมันน่าจาน้อยไป
ทำเปงคอนฟิก ไอพีเลย ครับ ไม่ทราบว่ามี server ไหมครับ
รับทำบัญชีชลบุรี,ตรวจสอบบัญชีชลบุรี,จดทะเบียนบริษัทชลบุรี,รับทำBOIชลบุรี 089-543-2716 k.หน่อย 081-3434037 k.ปู
http://www.diamondaccounting-boi.com/

ออฟไลน์ Yok

  • *****
  • 679
  • 41
  • เพศ: ชาย
ใช้ IP Address 192.168.x.y     (แปลงเป็นฐานสองก็จะได้           11000000.10101000.00000000.00000000 )
Sub netmask 255.255.252.0 (แปลงเป็นฐานสองก็จะได้           11111111.11111111.11111100.00000000 )
ผมเลือก 252 เพราะเมื่อแปลงเป็นฐานสองแล้วมันได้กลุ่มเลขสวยดี

คุณเอาตัวเลขฐานสองแต่ละหลักคูณกันจะได้ Network Address   11000000.10101000.00000000.00000000
เขียนใหม่ได้ว่า                                                                                 192.168.0.0/22

มองไปเลขฐานสองกลุ่มที่ผมขีดเส้นใต้เอาไว้ คือ 00.00000000
ตรงนี้คือ Host ที่เป็นได้ทั้งหมดของคุณ แปรค่าได้ตั้งแต่ 
          00.00000000 (ยกเว้น)
          00.00000001 (ค่าแรกที่ใช้ได้ของ /22)
          00.00000010
          00.00000011
          :
          00.11111111 (ยกเว้น)
          01.00000000 (ยกเว้น)
          01.00000001
          :
          01.11111111 (ยกเว้น)
          :
          11.11111110 (ค่าสุดท้ายที่ใช้ได้ของ /22)
          11.11111111 (ยกเว้น)

ดังนั้น Host Address มีได้ตั้งแต่
          192.168.0.1 ถึง 192.168.0.254     รวม   254 Hosts (ยกเว้น  192.168.0.0 กับ 192.168.0.255)
          192.168.1.1 ถึง 192.168.1.254     รวม   254 Hosts (ยกเว้น  192.168.1.0 กับ 192.168.1.255)
          192.168.2.1 ถึง 192.168.2.254     รวม   254 Hosts (ยกเว้น  192.168.2.0 กับ 192.168.2.255)
          192.168.3.1 ถึง 192.168.3.254     รวม   254 Hosts (ยกเว้น  192.168.3.0 กับ 192.168.3.255)
                                                                     รวม 1016 Hosts เหลือพอสำหรับ 400 กว่าเครื่องของบริษัทคุณครับ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ m_heart_mylove

  • *****
  • 33
  • 0
  • TH@min Membership
ใช้ IP Address 192.168.x.y     (แปลงเป็นฐานสองก็จะได้           11000000.10101000.00000000.00000000 )
Sub netmask 255.255.252.0 (แปลงเป็นฐานสองก็จะได้           11111111.11111111.11111100.00000000 )
ผมเลือก 252 เพราะเมื่อแปลงเป็นฐานสองแล้วมันได้กลุ่มเลขสวยดี

คุณเอาตัวเลขฐานสองแต่ละหลักคูณกันจะได้ Network Address   11000000.10101000.00000000.00000000
เขียนใหม่ได้ว่า                                                                                 192.168.0.0/22

มองไปเลขฐานสองกลุ่มที่ผมขีดเส้นใต้เอาไว้ คือ 00.00000000
ตรงนี้คือ Host ที่เป็นได้ทั้งหมดของคุณ แปรค่าได้ตั้งแต่ 
          00.00000000 (ยกเว้น)
          00.00000001 (ค่าแรกที่ใช้ได้ของ /22)
          00.00000010
          00.00000011
          :
          00.11111111 (ยกเว้น)
          01.00000000 (ยกเว้น)
          01.00000001
          :
          01.11111111 (ยกเว้น)
          :
          11.11111110 (ค่าสุดท้ายที่ใช้ได้ของ /22)
          11.11111111 (ยกเว้น)

ดังนั้น Host Address มีได้ตั้งแต่
          192.168.0.1 ถึง 192.168.0.254     รวม   254 Hosts (ยกเว้น  192.168.0.0 กับ 192.168.0.255)
          192.168.1.1 ถึง 192.168.1.254     รวม   254 Hosts (ยกเว้น  192.168.1.0 กับ 192.168.1.255)
          192.168.2.1 ถึง 192.168.2.254     รวม   254 Hosts (ยกเว้น  192.168.2.0 กับ 192.168.2.255)
          192.168.3.1 ถึง 192.168.3.254     รวม   254 Hosts (ยกเว้น  192.168.3.0 กับ 192.168.3.255)
                                                                     รวม 1016 Hosts เหลือพอสำหรับ 400 กว่าเครื่องของบริษัทคุณครับ

จะต้องมี server ที่ทำเป็น dhcp กี่ตัวครับ
แล้วต้อง config ที่ dhcp ยังไงบ้างครับ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ Yok

  • *****
  • 679
  • 41
  • เพศ: ชาย
ตามที่ผมตอบมาข้างต้นนั้น ผมไม่ได้แยกวง LAN นะครับ ทั้งหมดเป็นวงเดียวกัน เพียงแต่เป็น 4 segments

มีผู้เริ่มต้นใหม่หลายท่าน เข้าใจว่า 192.168.0.1 กับ 192.168.2.1 เป็นคนละวงเสมอ
อันนี้ไม่ถูกต้องครับ มันจะเป็นวงเดียวกันหรือคนละวง ก็ต้องดูที่ Network Address ด้วยครับ

โดยพื้นๆ เลยก็มีเพียง 1 DHCP Server Service ก็เพียงพอแล้ว แต่ถ้าจะให้ support ได้ดีขึ้นก็มี 2 DHCP ครับ
การ configure เหมือนเดิมทุกอย่าง คุณก็ระบุให้มันแจก IP Address ตามที่ผมระบุว่าเป็น Host Address
ส่วนจะต้อง reserver หรือละเว้นอะไรบ้าง ตรงนี้คุณต้องพิจารณาเพิ่มเติมเอง

**************************************************************************************
มีสมาชิกส่งข้อความมาถามผมว่าทำไมไม่ใช้ 255.255.0.0 ไปเลยง่ายดี เห็นหลายแห่งก็ใช้กัน
ใช้ได้ครับ แต่ถ้าคุณปฏิบัติงานแบบ "เต็มประสิทธิภาพ" คุณต้องพิจารณาอะไรๆ หลายๆ อย่าง
มากกว่าคำว่า "ง่ายดี" โดยเฉพาะเรื่อง Broadcast ครับ
255.255.0.0 อยู่ใน Class B ซึ่ง Network ที่จะใช้ Class B มักเป็น Network ขนาดใหญ่
เจอปัญหา Broadcast กันที ตามหาต้นตอกันจ้าละหวั่นครับ
ใช้ได้ครับไม่ผิด แค่เกินจำเป็นสำหรับเจ้าของกระทู้ ซึ่งระบุว่ามี 400 กว่าเครื่องครับท่าน
**************************************************************************************
« แก้ไขครั้งสุดท้าย: 14 กรกฎาคม 2009, 11:01:59 โดย Yok »
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

เนื่องจากอยากแจก DHCP โดย DHCP Server และมีuser 400
ผมว่า ถ้าจะทำจริงๆก็ยุ่งยากหน่อยครับ ที่ผมคิดได้มี2วิธีครับ
1. เปลี่ยน IP ทั้งหมดเป็น Class B ซึ่งก้อคงต้องมาแก้ Config กานพอสมควรครับ  :o
2. ตั้ง DHCP SERVER ของแต่ละวงครับ เช่น IP วง 192.168.1.1 ก็จะมี DHCP SERVER หนึ่งตัวเป้นผูแจก ซึ่งผมคิดว่า 3 วงใช้DHCP SERVER 3ตัวก็คงพอครับ
    แล้วก็ไปแก้ Config ที่ Router หรือ Firewall เอาครับ  O0
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ เทพห้านาที

  • ***
  • 665
  • 11
  • เพศ: ชาย
  • The quick brown mouse jumped over the lazy dog.
    • EECPMUT
บริษัทจะทำ DHCP แจก IP แต่เครื่องมีประมาณ 400 เครื่องควรจะออกแบบยังไงครับ
เพราะตอนนี้ที่ใช้ IP อยู่แยกเป็น 2 วงครับคือ 192.168.0.1 และ 192.168.1.1
ควรจะทำยังไงครับ
ขอบคุณครับ  :( :(
ผมแนะนำแบบนี้ครับ
คุณควรกำหนด DHCP scope แยกตามแผนก ไม่ก็ตามตึกตามชั้นก็ได้ครับ ผมบอกไม่ได้ว่าต้องมีกี่ scope เพราะไม่รู้โครงสร้างองค์กร แต่คร่าวๆก็น่าจะมีซัก 3-4 scope ขึ้นไป
แต่ละ scope ควรอยู่คนละ VLAN ครับ ส่วน DHCP Server มีแค่ตัวเดียวก็พอแล้วครับ แจก 4 scope ได้เลยไม่มีปัญหา ของผมตัวเดียวแจกเกือบ 10 กว่า scope เครื่อง client มากกว่าคุณสองเท่า ก็ยังรันได้สบายๆ มุ่งประเด็นไปเรื่องการจำกัดขอบเขตของ broadcast  ดีกว่า
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ jumpon_p

  • *
  • 199
  • 0
  • เพศ: ชาย
ถ้าไม่อยากแยกคนระวง แนะนำ ให้ ดูเรื่อง Subnet ครับ
<b>กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย</b>

kapookfff

จริงๆคุณน่าจะออกแบบเป้นขั้นตอนก่อนครับ อย่าเอาจำนวนเครื่องมากำหนด
เช่น ที่บริษัทมีกี่แผนก    มีกี่หนวยงาน   ที่จะต้องใช้ข้อมูลร่มกัน
     มีแผนกไหนบ้างที่ต้องใช้อินเตอร์เน็ต   ดูแค่นี้ก่อนครับ

   เสร็จแล้วคุณก็ใช้ server 2portGB  + swith L2 GB   
ใช้ bonded  2gb จาก server   เข้า swith   
swith แยกเป็น vlanแต่ละแผนก
แล้วมากำหนดใน server อีกทีว่าจะให้แผนกไหนมองเห็นกัน
จะให้ dhch  ใช้ fix ร่วมกันก็ได้ครับ

http://www.wirelessbkk.com/

ออฟไลน์ m_heart_mylove

  • *****
  • 33
  • 0
  • TH@min Membership
ผมแนะนำแบบนี้ครับ
คุณควรกำหนด DHCP scope แยกตามแผนก ไม่ก็ตามตึกตามชั้นก็ได้ครับ ผมบอกไม่ได้ว่าต้องมีกี่ scope เพราะไม่รู้โครงสร้างองค์กร แต่คร่าวๆก็น่าจะมีซัก 3-4 scope ขึ้นไป
แต่ละ scope ควรอยู่คนละ VLAN ครับ ส่วน DHCP Server มีแค่ตัวเดียวก็พอแล้วครับ แจก 4 scope ได้เลยไม่มีปัญหา ของผมตัวเดียวแจกเกือบ 10 กว่า scope เครื่อง client มากกว่าคุณสองเท่า ก็ยังรันได้สบายๆ มุ่งประเด็นไปเรื่องการจำกัดขอบเขตของ broadcast  ดีกว่า
ขอถามหน่อยนะครับถ้าทำอย่างที่คุณเทพห้านาทีแนะนำ
server ที่ทำ dhcp จะ config แต่ละ scope และ vlan ยังไงครับ
รบกวนด้วยครับ ( มือใหม่หัดทำ )
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ jumpon_p

  • *
  • 199
  • 0
  • เพศ: ชาย
config ที่ DHCP SErver ครับ ว่า จะให้มัน Pool ให้ Client เท่าไรถึงเท่าไรครับ ส่วน การทำ Vlan นั้น ต้องมี SW L2 ครับถึงทำได้
การทำ Vlan ก็ดีครับแยกแยะกันดีความปลอดภัยสูง แต่ถ้าไม่มี Vlan แล้วอยากให้อยู่ในวงเดียวกัน ก้อทำเรื่อง IP rang นั้นแหละครับ ง่ายสุดแล้ว
อย่างที่ถามมาว่า แล้วเซ็ตอย่างไรก้อพอจะรู้แล้วครับ ว่า มือใหม่  คงไม่ต้องพูดถึงขั้น Vlan หรอกครับ มันไม่ยากครับ แต่ซับซ้อน เอาไว้ให้ระบบต้องการความปลอดภัยสูงค่อยว่ากันอีกที


เมื่อ: 15 กรกฎาคม 2009, 08:41:21
หาพวกหนังสือเกี่ยวกับการ Set Server เบื้องต้นมาอ่านดูนะครับ อย่างเช่น windows server 2000 ในห้วข้อ DHCP ครับมันจะสอนวิธีการ Set ครับ
<b>กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย</b>

ออฟไลน์ Yok

  • *****
  • 679
  • 41
  • เพศ: ชาย
อ้างถึง
เห็นด้วยตามที่คุณ jumpon_p ตอบกระทู้มาครับ

ประเมินจากคำถามของเจ้าของกระทู้ น่าจะเป็นมือใหม่ หรือมีประสบการณ์ไม่มากนัก
ผมจึงตอบกระทู้แบบง่ายสุดๆ แล้ว ทำให้ได้ตามนั้นก่อน
ส่วนจะเติบโตขึ้น มี Secure มากขึ้นอย่างไรก็ค่อยต่อยอดภายหลัง

ประเด็นที่บอกว่า "อย่าเอาจำนวนเครื่องมาเป็นข้อกำหนด" ต้องขออนุญาตค้านเลยครับ
ทุกวันนี้ Admin ทั้งหลายดูแลระบบเครือข่ายกันยากง่าย วุ่ยวาย สับสนหรือไม่ก็ตรง "จำนวนเครื่อง" นี่แหละครับ

หากวันนี้ไม่คำนึงถึงจำนวนเครืjองที่มีอยู่แล้ว จำนวนเครื่องที่วางแผนในอนาคต 3-5 ปี
ถึงวันนั้นคุณก็ต้องเสียเวลารื้อระบบ จัดวางขุมกำลังกันอีกรอบหนึ่ง
ข้อโต้แย้งของผมคือ จำนวนเครื่องลูกข่าย มีผลอย่างมากในการวางแผนการจัดการระบบเครือข่าย
ทุกๆ เรื่องทั้ง AD, DC, DNS Zone, DHCP, VLAN, VPN, Internet Proxy, GPO, Infrastructure ฯลฯ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ ~ RoNiN ~

  • *****
  • 553
  • 7
  • เพศ: ชาย
  • ทำดีแต่อย่าเด่นจะเป็นภัย
ไม่เห็นเจ้าของกระทู้บอกเลยครับว่ามีอะไรนอกจากเครื่องบ้าง  :P

ที่อยากให้สนใจกว่า 400 น่าจะมีอย่างอื่นอีกนะครับ

สิ่งที่มีทั้งหมด PC 400 router switch สาขาอื่นๆหรืออยู่ที่เดียวกันหมด บลาๆๆๆๆๆๆ
สิ่งที่อยากให้เป็น แผนกนู้น กับแผนกนั้นและแผนกนี้ รวมแล้ว 150 ตัวใช้อินเตอร์เน็ทได้ ที่เหลือ ให้เฝ้าสำนักงาน และ บลาๆๆๆๆ
สิ่งที่อาจจะมีเพิ่มเติม สาขาจากที่โน้น จะเข้ามาหา ไฟล์เซิร์ฟเวอร์ที่นี่ และที่นั่นอาจจะขอใช้เมล์จากที่นี่ และบลาๆๆๆ

ผมว่ามันไม่มีอะไรตายตัวนะ มันจะมีแค่ดีกับดีกว่า แต่ตัวแปรของทั้งหมดคือระบบที่มันมี และสิ่งที่อยากให้มันเป็น

คำถามสั้นๆที่ว่า "บริษัทจะทำ DHCP แจก IP แต่เครื่องมีประมาณ 400 เครื่องควรจะออกแบบยังไงครับ"

มักจะได้คำตอบยาวๆเสมอครับ O0

จำนวนไม่สำคัญเท่ามุมที่มองอยู่ครับ การออกแบบมันก็น่าจะเป็นเช่นนั้นแล.....



Hello Thailand

ออฟไลน์ Devman

  • *****
  • 3,609
  • 85
  • เพศ: ชาย
  • กล้าที่จะลอง เพื่อสิ่งที่ดีกว่า
น่าทำเป็น กระทู้ศึกษา นะครับ ขอปักหมุดไว้ละกัน

ออฟไลน์ sf_alpha

  • *****
  • 3,936
  • 89
  • เพศ: ชาย
  • The SF-Alpha
    • My Profiles
จริง ๆ 400 ผมว่าถ้า broadcast มันไม่มากนักก็ไม่ต้ิองแยก VLAN ได้นะ เพราะเท่าที่้เจอ ๆ มาต้องสัก 500 ขึ้นถึงจะเริ่มมี broadcast เยอะจริง ๆ จนเกิดปัญหา

แต่ 1 VLAN ก็ไม่ควรเกิน 1000 client อยู่ดีเพื่อป้องกันปัญหาจาก Switch ห่วย ๆ )(5 port, 8 port) ที่บางทีเกิด MAC Address Table น้อย เช่นแค่ 1000

อีกอย่างมันขึ้นกับว่า switch ที่ใช้ในระบบเป็นแบบไหน managed หรือไม่ ฯลฯ มันต้องเอามาดูร่วมด้วย ถ้าเป็น managed ทั้งหมดผมแบ่ง VLAN แล้วใช้ port secure แยก VLAN ตาม MAC อัตโนมัติไปเลย เครื่องแปลกปลอมก็โยนเข้า guest vlan ได้ด้วย

ผมก็อยากรู้เหมือนกันครับ  ว่า  การทำให้ ขยาย IP  เพิ่มขึ้น ทำกันอย่างไง

เพราะผมก็คงมีไม่เกิน  255  เครื่อง แต่ถ้าเกิน จะทำอย่างไร
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

bunmanetwork

แนวคิดดีๆทั้งนั้นครับ

ถ้าเจ้าของกระทู้ ตั้งคำถามแนวนี้
เอาเป็นว่า ท่านจะเป็น IT Management ของบริษัทนี้
คนที่จะมาช่วย ก็น่าจะเป็น Network Admin ได้ แปลว่าต้องมีความเข่าใจเกี่ยวกับ Computer network โดยทำ SA ก่อน

แต่ถ้ายังไม่มี ลองขีดๆเขียนๆเป็น flow chart ออกมาให้ได้ก่อน ถ้าหาความต้องการ หรือจัดการรอบด้านแล้ว ผมว่า Linux สำเร็จรูป (เขาเรียกอะไรจำไม่ได้แหละ)
เช่น Pfsense,Clack connect ,IPcop มาลองดูเป็น GUI ที่จะมีความสามารถควบคุมตามความต้องการ และทำให้มอง Server-Firewall ออกมากขึ้น

ออฟไลน์ pipop

  • *****
  • 6
  • 0
DHCP   = 192.168.0.1 - 192.168.3.254
Subnet  = 255.255.252.0     -----------++++  (1xxx  IP)
Getway = 192.168.0.1

-----------จบ---

กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ m_heart_mylove

  • *****
  • 33
  • 0
  • TH@min Membership
ผมแนะนำแบบนี้ครับ
คุณควรกำหนด DHCP scope แยกตามแผนก ไม่ก็ตามตึกตามชั้นก็ได้ครับ ผมบอกไม่ได้ว่าต้องมีกี่ scope เพราะไม่รู้โครงสร้างองค์กร แต่คร่าวๆก็น่าจะมีซัก 3-4 scope ขึ้นไป
แต่ละ scope ควรอยู่คนละ VLAN ครับ ส่วน DHCP Server มีแค่ตัวเดียวก็พอแล้วครับ แจก 4 scope ได้เลยไม่มีปัญหา ของผมตัวเดียวแจกเกือบ 10 กว่า scope เครื่อง client มากกว่าคุณสองเท่า ก็ยังรันได้สบายๆ มุ่งประเด็นไปเรื่องการจำกัดขอบเขตของ broadcast  ดีกว่า
ขอบคุณสำหรับทุกคำตอบ(thaiadmin) นะครับที่ทำให้ผมได้ทางออกมากขึ้น
ขอบคุณ  คุณเทพห้านาทีนะครับผมก็คิดว่าจะทำตามที่แนะนำ
คือกำหนด DHCP scope แยกตามแผนกและก็อยู่คนละ VLAN ด้วยครับ
ผมได้แนบ network diagram มาให้ดูด้วยครับ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ เทพห้านาที

  • ***
  • 665
  • 11
  • เพศ: ชาย
  • The quick brown mouse jumped over the lazy dog.
    • EECPMUT
วันนี้เอารูปมาให้ดูเพิ่มเติมครับ capture มาได้ไม่หมด มันยาวเกิน  O0

กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

Bankham

แบ่งเป็นหลาย segment นั้นถูกต้องแล้วครับ จะใช้ DHCP Server กี่ตัวก็ได้ ผลต่างกันเล็กน้อยครับ แต่ทางที่ดีควรตระหนักถึงเรื่องนี้ด้วยครับ

1.ปัญหา Traffic ที่หนาแน่นมาก ถ้า segment นั้นหรือ scope นั้นใหญ่เกินไปครับ
2.ที่ต้องทำแน่นอนคือ vlan นะครับ ถ้าไม่มี vlan เนี่ยถือว่าเน็ทเวิร์กของคุณเสี่ยงสุดๆสำหรับการติด Virus นะครับ เพราะมันจะทำการ Broadcast ไปยังทุกเครื่องที่อยู่ในเน็ทเวิร์กเดียวกันอย่างแน่นอน แ ต่ถ้าเรามี vlan เข้ามาช่วยล่ะก็ มันจะติดเป็นกลุ่มๆ เฉพาะ vlan ของตัวเองครับ  และที่สำคัญมัน Main System Traffic จะน้อยครับ ทำให้ไม่เกิดปัญหาเรื่อง Session บนอุปกรณ์ Router หรือ Firewall Router หรือ Switch เต็ม หรือค้างต่างๆ นาๆ เพราะถ้าเป็นอย่างนั้นจริงๆละก็ งานของคุณไม่เดินแน่นอนครับ
3.System Devices Sharing ถ้ามีอะไรที่ต้องใช้งานร่วมกันก็จัดให้มันอยู่ในทุก vlan ซะหรือสามารถ allow ได้ว่าจะให้ vlan ไหนคุยกันได้ และ vlan ไหนคุยกันไม่ได้

คำนึงถึง Scope / Vlan / Department    นะครับ  จัดไป อย่าให้เสีย

ออฟไลน์ networker

  • **
  • 159
  • 0
  • จุงเบย
ง่ายมากเลยครับคุณมีกี่แผนกคุณก็แยก network ตามนั้นได้เลยครับจะได้จำกัด เรื่อง collision domain ได้ครับ เช่น
คุณมี 5 แผนกคุณก็แบ่งตามนี้
192.168.1.x
192.168.2.x
192.168.3.x
192.168.4.x
192.168.5.x

ถ้าคุณมี dhcp server คุณก็ให้ DHCP แจก ไม่มีก็ fix ip address ได้ จะได้จำกัดรื่อง virus ด้วยครับ
จุง เบย

ออฟไลน์ m_heart_mylove

  • *****
  • 33
  • 0
  • TH@min Membership
แล้วต้อง config ยังไงครับ ให้แต่ละแผนกรับ dhcp ของ scope ไหน
อย่างเช่น
       scope 192.168.1.x marketing
       scope 192.168.2.x accounting
       scope 192.168.3.x ......
       scope 192.168.4.x ........
ต้อง config ยังไงครับ ช่วยที
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

Pongarmat_l

ผมขอแนะนำปัจจัยที่น่าจะนำมาเป็นเงื่อนไขในการออกแบบครับ
1. จำนวนเครื่องทั้งหมด
              **** ใช้ Subnet เป็นตัวกำหนดก็ได้ *********
2 .ต้องรู้ว่าในจำนวนเครื่องทั้งหมดนั้นให้สามารถเข้าแชร์ข้อมูลกันได้ทั้งหมด หรือว่ให้าแต่ล่ะแผนกไม่สามารถเข้าถึงข้อมูลของอีกแผนกได้
            ****** ทำ Vlan เพื่อแบ่งทีล่ะแผกออกจากกัน ********
     ///***** สำหรับอุปกรณ์ที่ใช้ มี  DHCP Server/Router/Switch L2*******//

ออฟไลน์ edwin

  • ***
  • 72
  • 1
  • TH@min Membership
แล้วต้อง config ยังไงครับ ให้แต่ละแผนกรับ dhcp ของ scope ไหน
อย่างเช่น
       scope 192.168.1.x marketing
       scope 192.168.2.x accounting
       scope 192.168.3.x ......
       scope 192.168.4.x ........
ต้อง config ยังไงครับ ช่วยที

เห็นด้วยครับสำหรับการทำ VLAN เพื่อลดในเรื่องของการ Broadcasting และเรื่องโอกาศที่จะติด Virus แต่การที่คุณจะทำ DHCP serverเพื่อให้ assign IP ของแต่ละ VLAN คุณจะต้องมี DHCP Relay ครับเพื่อให้ให้มันตัวส่ง broadcast request ไปหา DHCP server ว่า Interface VLAN ไหน เป็นผู้ร้องขอ เพือให้ DHCP แจก IP มาได้อย่างถูกต้องตาม Pool ที่กำหนดไว้ครับ ซึ่งใน L3 switch ก็มี Feature นี้อยู่ครับ ยังไงลองดูครับ หรือลองท่านอื่นแนะนำเพิ่มเติมครับ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ m_heart_mylove

  • *****
  • 33
  • 0
  • TH@min Membership
ผมขอแนะนำปัจจัยที่น่าจะนำมาเป็นเงื่อนไขในการออกแบบครับ
1. จำนวนเครื่องทั้งหมด
              **** ใช้ Subnet เป็นตัวกำหนดก็ได้ *********
2 .ต้องรู้ว่าในจำนวนเครื่องทั้งหมดนั้นให้สามารถเข้าแชร์ข้อมูลกันได้ทั้งหมด หรือว่ให้าแต่ล่ะแผนกไม่สามารถเข้าถึงข้อมูลของอีกแผนกได้
            ****** ทำ Vlan เพื่อแบ่งทีล่ะแผกออกจากกัน ********
     ///***** สำหรับอุปกรณ์ที่ใช้ มี  DHCP Server/Router/Switch L2*******//
ขอถามเกี่ยวกับ ข้อ 2. หน่อยนะครับ
การทำ VLAN สมมุติว่าผมแบ่ง VLAN ตามแผนก แต่บางเครื่องของแต่ละ VLAN สามารถที่จะแชร์ข้อมูลหากันได้
ในเรื่องของการ Broadcast จะยังจำกัดอยู่ใช่ไหมครับ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ cycob69

  • *
  • 263
  • -3
  • เพศ: ชาย
ทั้งหลายทั้งปวง ถ้า SW Manage ไม่ได้ก้อจบ แต่ถ้าได้ก้อแบ่ง VLAN ที่ switch เดี๋ยวมันก้อวิ่งไปตามทางของมัน
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ networker

  • **
  • 159
  • 0
  • จุงเบย
เมื่อคุณทำการแบ่ง Vlan แล้ว การ Broadcast จะถูกจำกัดไว้ใน VLAN นั้นๆ ครับการที่คุณจะวิ่งข้าม VLAN คุยกันจำเป็นต้องมี Layer3 ซื่งก็คือ router นั่นเองครับไม่งั้นแบ่ง VLAN ไปคุณคุยข้าม VLAN กันไม่ได้ครับ

จุง เบย

ถือเป็น Case Study ที่ดีมากๆ อีกที่นึงเลยครับ สำหรับผู้เริ่มต้นครับผม
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ เต่าปัง

  • ***
  • 71
  • 0
  • เพศ: ชาย
  • ยินดีที่ได้รู้จักคับ"
กรณี BroadCast Domain มีปัญหาที่ทำให้เครื่อง client ต้องจับแพคเกจมาอ่านชั่วขณะนึง
จะมีผลกระทบในตอนที่ไม่ได้แบ่ง VLAN แล้วมี broadcast มาจากหลายร้อยเครื่อง
ทำให้เป็นผลเสียต่อการใช้งานของเครื่อง Client ทุกเครื่องที่จะต้องเสียเวลามานั่งจับแพกเกจด้วยคับ
คนเปิดกระทู้ แล้วอย่าลืมมาปิดกระทู้ให้ทราบด้วยนะครั บคนพบปัญหาจะได้ประโยชน์กัน ^^ lol

ออฟไลน์ ipconfig54

  • ****
  • 224
  • 1
  • เพศ: ชาย
  • ทำวันนี้ให้ดีที่สุด เพื่ออนาคตในวันข้างหน้า
ผมว่าทำตามท่าน เทพห้านาที เป็นแนวทางที่ดีนะครับ 1Server  สร้าง Scope ตามแผนกหรือว่าแบบ ตามตึก หรือตามจำนวนชั้นของตึก แล้วแต่จำนวนเครื่องและ admin งานต่อการจัดการและการจดจำครับ
<b>กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย</b>

192.168.1.x
192.168.2.x
192.168.3.x
192.168.4.x
192.168.5.x

แล้วๆๆ DHCP ต้องกำหนด เลข ยังไงหรอครับ เช่น 192.168.1.x - 192.168.5.x  แบบนี้หรอครับ
เมื่อ: 05 ธันวาคม 2009, 23:38:32
192.168.1.x
192.168.2.x
192.168.3.x
192.168.4.x
192.168.5.x
แล้วๆๆ DHCP ต้องกำหนด เลข ยังไงหรอครับ เช่น 192.168.1.x - 192.168.5.x  แบบนี้หรอครับ

แล้วการ broadcast โดยแต่ละ class แล้ว ไม่ควรให้มันเกิน class ละ กี่เครื่อง ครับ ถึงจะstable(เสถียร) สุด
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

2012

ให้ใช้ class B แล้วใช้ mask มากำหนด host ให้มีจำนวนใกล้เคียงกับที่ต้องการมากที่สุดครับอย่างเช่นในกรณีนี้ ต้องการ 400 host ดังนั้น แสดงว่า host ต้องเป็น 9 bit และ subnet  7  bit เช่น 192(network).168(network).x(subnet).0(host)/255.255.254.0 หรือยกตัวอย่างง่าย ๅ คือคุณกำหนดให้ dhcp server จ่าย ip scope = 192.168.15.0 , mask = 255.255.254.0 แค่นี้คุณก็จะได้ 510 ip แล้วครับ (2^9 -2)

2012

^
^
ผมขอแก้ไข จาก"กำหนดให้ dhcp server จ่าย ip scope = 192.168.15.0 " เป็น 192.168.0.0 , mask = 255.255.254.0 ครับผม

ออฟไลน์ Cisco_SiengKong

  • *****
  • 181
  • 0
  • ชิสโก้_เชียงกง เจ้าของเดียวกับ เชียงกง คอมพิวเตอร์
เอา เป็น ว่า ราคา server + เวลาทำงาน = กี่บาท
หลานหมื่นอยู่ อะครับ

สรุป ง่าย เร็ว เสถียน ตอบโจยท์ ครบ  เอาไปเลย L# 3 switch

ทำ vlan  >> จะเอาสังกี่วง ว่ามา... 64 vlan Domain Routting พอมัย  = 64 แผนกที่คุณอยากจะมี
จ่าย dhcp แต่ละวง... จ่ายได้ทุกวง อิสระจากกัน

ใช้เวลา config ไม่เกิน 30 นาที จบ >> เวบ config ด้วย
ลงทุนไม่เกิน 3 หมื่นครับ.. 24 port 10/100 2 port /1000 2 port sfp >> รองรับ fiber ด้วย
ฟรี ติดตั้ง อีก ต่างหาก...
ตอนนี้ใช้อยู่ ดี มั๊กๆ

จบข่าว เรียบร้อย โรงเรียน จีน.. คิคิ  O0


 
ให้เช่า cisco Router+switch ราคาเริ่มตั้น 800/เดือน
อุปกรณ์เสีย มีปัญหา เปลี่ยนตัวใหม่ทันที มีบริการถึงสถานที่ติดตั้ง
พร้อมบริการ config และติดตั้งทั่วไทย
เราอาจสามารถช่วยลดค่าใช้จ่ายและภาระของท่าน ได้

** มีบริการเดินสาย fiber optic ทั่วราชอณาจักร ด้วยนะครับ**

ออฟไลน์ Zouchii

  • ****
  • 120
  • 0
  • เพศ: ชาย
พอจะมีใครทำเป็น scenario ให้เห็นเป็นภาพได้บ้างครับ ยกตัวอย่าง อย่างง่ายที่ควรจะทำ เช่น
  1. มีแผนก 5 แผนก แต่ละแผนกมีประมาณ 80 เครื่อง
  2. มี Switch L2 กี่ตัว แต่เซ็ตอย่างไรบ้าง
  3. ต้องมี Server ทำ DHCP กี่ตัวตั้งค่าอย่างไรบ้าง windows กับ Linux อะไรก็ได้เป็นคอนเซ็ป
  4 อื่นๆ

ผมเองก็มีความสนใจอยู่แต่ ต่างคนต่างถาม ต่างประเด็น บางทีอ่านแล้วก็งง ไม่รู้จะเริ่มยังไง
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ =:barbarian:=

  • *****
  • 1,005
  • 0
  • เพศ: ชาย
  • Extremes of life...
    • 。◕ parprew.info ◕。
พอจะมีใครทำเป็น scenario ให้เห็นเป็นภาพได้บ้างครับ ยกตัวอย่าง อย่างง่ายที่ควรจะทำ เช่น
  1. มีแผนก 5 แผนก แต่ละแผนกมีประมาณ 80 เครื่อง
  2. มี Switch L2 กี่ตัว แต่เซ็ตอย่างไรบ้าง
  3. ต้องมี Server ทำ DHCP กี่ตัวตั้งค่าอย่างไรบ้าง windows กับ Linux อะไรก็ได้เป็นคอนเซ็ป
  4 อื่นๆ

ผมเองก็มีความสนใจอยู่แต่ ต่างคนต่างถาม ต่างประเด็น บางทีอ่านแล้วก็งง ไม่รู้จะเริ่มยังไง
ตกลง จขกท.ทำไปรึยัง ทำแบบใหน
<you/> [you/]

ออฟไลน์ เด็กด้อยโอกาส

  • *****
  • 186
  • 0
  • เพศ: ชาย
  • เด็กน้อย ด้อยโอกาส
    • http://www.diamondaccounting-boi.com/
ผมว่าใช้ server จัดการดีกว่าครับ สัก 2 ตัว หรือ3 ตัว จัดการง่ายกว่า ปกติ คอนฟิกไอพีเอาครับ หรือ set domain เอาครับ
รับทำบัญชีชลบุรี,ตรวจสอบบัญชีชลบุรี,จดทะเบียนบริษัทชลบุรี,รับทำBOIชลบุรี 089-543-2716 k.หน่อย 081-3434037 k.ปู
http://www.diamondaccounting-boi.com/

nudragonjung0012

ผมว่าจากจะทำVlanนะครับเพราะถ้าในองค์กรมีข้อมูลสำคัญควรเป็นอย่างยิ่งที่จะทำเพราะอย่างองค์กรที่ผมทำอยู่เน้นเรื่องของSecurityมากๆแต่ถ้าเพื่อให้ใช้งานอินเตอร์เน็ตเฉยๆก็ทำscope เฉยๆก็okครับ

ออฟไลน์ cycob69

  • *
  • 263
  • -3
  • เพศ: ชาย
ผมว่าคุณไปดูใน บ. คุณก่อนดีกว่าว่ามีหน่วยงานอะไรบ้าง แต่ละหน่วยงานมีเท่าไหร่ แล้วทำเป็น vlan ( แบ่งเป็น network ไปเลย) สมมุติน่ะ มีสัก 4 หน่วยแต่ละหน่วยมี 100 ง่ายๆก็

192.168.1.0/24
192.168.2.0/24
192.168.3.0/24
192.168.4.0/24

แค่เนี้ยก็พอ เวลามีปัญหาตามหาโจทย์ง่ายด้วย เครื่องไหนติดไวรัส ปล่อยอะไรออกมากวนระบบ จะได้ตามตัวได้ถูก แค่เนี้ยก็พอแล้ว
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

qeev

ผมว่าคุณไปดูใน บ. คุณก่อนดีกว่าว่ามีหน่วยงานอะไรบ้าง แต่ละหน่วยงานมีเท่าไหร่ แล้วทำเป็น vlan ( แบ่งเป็น network ไปเลย) สมมุติน่ะ มีสัก 4 หน่วยแต่ละหน่วยมี 100 ง่ายๆก็

192.168.1.0/24
192.168.2.0/24
192.168.3.0/24
192.168.4.0/24

แค่เนี้ยก็พอ เวลามีปัญหาตามหาโจทย์ง่ายด้วย เครื่องไหนติดไวรัส ปล่อยอะไรออกมากวนระบบ จะได้ตามตัวได้ถูก แค่เนี้ยก็พอแล้ว

เห็นด้วยนะครับ  ให้ผมแนะนำตามนี้ครับ

1 จะแบ่งกลุ่มเครื่องอย่างไร?  ตามแผนก หรือว่า ตาม ชั้นของตึกก็ได้
2. กลุ่มยิ่งเล็ก ก็ยิ่งดี เพราะ broadcast จะน้อยลง แต่ก็จะจัดการยากขึ้น
3. กลุ่มของ Wireless ควรจะแยกเลยมาต่อกับ firewall  หากไม่มีWireless securityนะครับ  อันนี้ขึนอยู่กับ วัตถุประสงค์ของการแบ่งกลุ่ม Wireless
4. DHCP นั้นถ้า 400 IP  แบ่งได้สบายอยู่แล้ว และใช้งานร่วมกับ switch Layer 3 พร้อมแบ่ง VLAN และใช้ function DHCP relay ตาม VLAN

หวังว่าพอจะเป็นแนวทางได้นะครับ?


ผมว่าน่าจะแบ่งเป็นโซนอะครับ
ประมาณ 3-4 โซน
โดยที่ให้  router เป็นตัวแจก DHCP  ครับ
น่าจะดีกว่า  แล้วง่ายต่อการตรวจซ่อม
 :) ;) ;D

ออฟไลน์ boonsin

  • *
  • 13
  • 0
เห็นด้วยนะครับ  ให้ผมแนะนำตามนี้ครับ

1 จะแบ่งกลุ่มเครื่องอย่างไร?  ตามแผนก หรือว่า ตาม ชั้นของตึกก็ได้
2. กลุ่มยิ่งเล็ก ก็ยิ่งดี เพราะ broadcast จะน้อยลง แต่ก็จะจัดการยากขึ้น
3. กลุ่มของ Wireless ควรจะแยกเลยมาต่อกับ firewall  หากไม่มีWireless securityนะครับ  อันนี้ขึนอยู่กับ วัตถุประสงค์ของการแบ่งกลุ่ม Wireless
4. DHCP นั้นถ้า 400 IP  แบ่งได้สบายอยู่แล้ว และใช้งานร่วมกับ switch Layer 3 พร้อมแบ่ง VLAN และใช้ function DHCP relay ตาม VLAN

หวังว่าพอจะเป็นแนวทางได้นะครับ?

ครับผม เห็นด้วยครับ แล้วก็ทำ Scope บน DHCP ตาม IP ของแต่ละกลุ่มที่สร้าง Vlan ขึ้นมาครับ

ออฟไลน์ Taciosoft™

  • ****
  • 227
  • 0
  • เพศ: ชาย
  • อิสระในการใช้ชีวิต......คือการไม่ยึดติดกับปัญหา
    • www.it-consultsolution.com
ใช้ IP Address 192.168.x.y     (แปลงเป็นฐานสองก็จะได้           11000000.10101000.00000000.00000000 )
Sub netmask 255.255.252.0 (แปลงเป็นฐานสองก็จะได้           11111111.11111111.11111100.00000000 )
ผม เลือก 252 เพราะเมื่อแปลงเป็นฐานสองแล้วมันได้กลุ่มเลขสวยดี

คุณเอา ตัวเลขฐานสองแต่ละหลักคูณกันจะได้ Network Address   11000000.10101000.00000000.00000000
เขียน ใหม่ได้ว่า                                                                                 192.168.0.0/22

มองไปเลขฐานสองกลุ่มที่ผมขีดเส้น ใต้เอาไว้ คือ 00.00000000
ตรงนี้คือ Host ที่เป็นได้ทั้งหมดของคุณ แปรค่าได้ตั้งแต่
          00.00000000 (ยกเว้น)
          00.00000001 (ค่าแรกที่ใช้ได้ของ /22)
          00.00000010
          00.00000011
          :
          00.11111111 (ยกเว้น)
          01.00000000 (ยกเว้น)
          01.00000001
          :
          01.11111111 (ยกเว้น)
          :
          11.11111110 (ค่าสุดท้ายที่ใช้ได้ของ /22)
          11.11111111 (ยกเว้น)

ดัง นั้น Host Address มีได้ตั้งแต่
          192.168.0.1 ถึง 192.168.0.254     รวม   254 Hosts (ยกเว้น  192.168.0.0 กับ 192.168.0.255)
          192.168.1.1 ถึง 192.168.1.254     รวม   254 Hosts (ยกเว้น  192.168.1.0 กับ 192.168.1.255)
          192.168.2.1 ถึง 192.168.2.254     รวม   254 Hosts (ยกเว้น  192.168.2.0 กับ 192.168.2.255)
          192.168.3.1 ถึง 192.168.3.254     รวม   254 Hosts (ยกเว้น  192.168.3.0 กับ 192.168.3.255)
                                                                     รวม 1016 Hosts เหลือพอสำหรับ 400 กว่าเครื่องของบริษัทคุณครับ

อ้างอิงครับ[/glow]


ออฟไลน์ cutout

  • **
  • 40
  • 0
ถ้าจะแนะนำให้ไปศึกษาเรื่อง vlsm มันจะโหดไปไหมครับ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ Cisco_SiengKong

  • *****
  • 181
  • 0
  • ชิสโก้_เชียงกง เจ้าของเดียวกับ เชียงกง คอมพิวเตอร์
หลายท่านก็แนะนำได้ดีครับ
แต่ความเห็นผมว่า VLAN น่าจะเป็นคำตอบที่ดี เพราะจะช่วยเรื่อง preferment ของระบบโดยรวม
ใหนจะเรื่อง broadcasts domain

เพื่อจัดการระบบของเราเป็นหมวดหมู่
ครั้งจะเอา pc หรือ server มาแบ่งมันก็ได้อยู่  ประหยัด...ใช้งานได้
แต่ความสเถียนละครับ วันดีคืนดี HDD พังจบข่าวเลย...
การติดตั้ง config ก็จะยุ่งยาก มือใหม่ก็จะลำบาก..
วันใหนคุณไม่อยู่  คนอื่นจะมาดูแลต่อก็ยากนะครับ..
กลายเป็นระบบส่วนบุคคล.... คือคนอื่นมาทำต่อก็ต้องเทพเหมือนกัน..


มีงบซื้อคอมจนมี 400 เครื่อง...

L3 swich ตัวหนึ่งไม่กี่หมื่นเองครับ.. งบประมานด้านเครื่อข่ายคิดเป็น % ของ IT ทั้งหมด ไม่กี่บาทหรอกครับ
ได้เรื่องจ่าย IP  ตัว switch มันทำได้ในตัวอยู่แล้ว..

แก้ปัญหาที่ต้นเหตุดีกว่ามัยครับพี่ครับ
 
ให้เช่า cisco Router+switch ราคาเริ่มตั้น 800/เดือน
อุปกรณ์เสีย มีปัญหา เปลี่ยนตัวใหม่ทันที มีบริการถึงสถานที่ติดตั้ง
พร้อมบริการ config และติดตั้งทั่วไทย
เราอาจสามารถช่วยลดค่าใช้จ่ายและภาระของท่าน ได้

** มีบริการเดินสาย fiber optic ทั่วราชอณาจักร ด้วยนะครับ**

ใช้ l3 ทำ vlan  ครับ แต่ต้องเอา Balancing  มาช่วยในส่วนของinternet ถ้ามี2 line  แต่ถ้ามี line 1 ก็ไม่ต้อง ที่ผมเคยใช้มัน 300 ทำ l3 แบง vlan  ก็ช้ได้ครับ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ aoskn

  • *****
  • 9
  • 0
ทำ แบ่ง subnet โดยเราเอา ใช้ ip เช่น 192.168.1.1 255.255.254.0 แบบนี้ก็ได้หรือ จะแบ่งเป็น 2 วง แล้วทำการ routing กันก็ได้

ออฟไลน์ Exzthy

  • *****
  • 7
  • 0
หลายท่านก็แนะนำได้ดีครับ
แต่ความเห็นผมว่า VLAN น่าจะเป็นคำตอบที่ดี เพราะจะช่วยเรื่อง preferment ของระบบโดยรวม
ใหนจะเรื่อง broadcasts domain

เพื่อจัดการระบบของเราเป็นหมวดหมู่
ครั้งจะเอา pc หรือ server มาแบ่งมันก็ได้อยู่  ประหยัด...ใช้งานได้
แต่ความสเถียนละครับ วันดีคืนดี HDD พังจบข่าวเลย...
การติดตั้ง config ก็จะยุ่งยาก มือใหม่ก็จะลำบาก..
วันใหนคุณไม่อยู่  คนอื่นจะมาดูแลต่อก็ยากนะครับ..
กลายเป็นระบบส่วนบุคคล.... คือคนอื่นมาทำต่อก็ต้องเทพเหมือนกัน..

มีงบซื้อคอมจนมี 400 เครื่อง...

L3 swich ตัวหนึ่งไม่กี่หมื่นเองครับ.. งบประมานด้านเครื่อข่ายคิดเป็น % ของ IT ทั้งหมด ไม่กี่บาทหรอกครับ
ได้เรื่องจ่าย IP  ตัว switch มันทำได้ในตัวอยู่แล้ว..

แก้ปัญหาที่ต้นเหตุดีกว่ามัยครับพี่ครับ
 

ผมเห็นด้วยนะครับมีงบซื้อ PC กว่า 400 เครื่อง
Switch L3 ตัวเดียว ตอบโจทย์นี้ได้หมดเลยจริงๆ
เมื่อ: 25 สิงหาคม 2010, 01:32:13
เห็นบางท่านยัง งงๆกับการทำ Vlsm ผมเลยมีคลิปการทำมาฝากครับเรียนรู้ไม่ยากจริงๆ


http://www.youtube.com/watch?v=YLwGGPNT2uc

http://www.youtube.com/watch?v=_2iJaNusMXw

ผมรับรองว่าหากได้อ่านทำความเข้าใจและดูจากขั้นตอนแล้ว ทำได้แน่นอนครับ :)

ออฟไลน์ Zouchii

  • ****
  • 120
  • 0
  • เพศ: ชาย
ผมอยากรู้นะครับ ถ้าเราทำ VLAN อย่างที่หลายท่านบอกแล้วแบ่งตาม แผนกของบริษัท แล้วสร้าง DHCP ขึ้นมาหลายๆวง เช่น 192.168.0.1 - 192.168.0.254    Server
       192.168.1.1 - 192.168.1.254    Account
             |     -       | 
       192.168.20.1 - 192.168.20.254 Manager Group  เป็นต้นนะครับ

    แล้วจากนั้นผมต้องตั้งค่าอะไรใน Switch L3 ถึงจะทำการแจก IP ได้ถูกต้องตามแผนกนะครับ สงสัยอย่างแรง
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ janyut

  • ***
  • 3
  • 0
  • เพศ: ชาย
ที่ L3 Switch

interface Vlan1 < ชื่อ Vlan
ip address 192.168.1.1  255.255.255.0 < IP Gateway ของ interface Vlan1
ip helper-address 192.168.0.1  < IP DHCP

interface Vlan2 < ชื่อ Vlan
ip address 192.168.2.1  255.255.255.0 < IP Gateway ของ interface Vlan2
ip helper-address 192.168.0.1  < IP DHCP

interface Vlan3 < ชื่อ Vlan
ip address 192.168.3.1  255.255.255.0 < IP Gateway ของ interface Vlan3
ip helper-address 192.168.0.1  < IP DHCP

interface Vlan4 < ชื่อ Vlan
ip address 192.168.4.1  255.255.255.0 < IP Gateway ของ interface Vlan4
ip helper-address 192.168.0.1  < IP DHCP


ที่ DHCP Server ไฟล์ dhcp.conf

subnet 192.168.1.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.1.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Account";
        range 192.168.1.2 192.168.1.254;

        option broadcast-address 192.168.1.255;

}

subnet 192.168.2.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.2.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Manager";
        range 192.168.1.2 192.168.2.254;

        option broadcast-address 192.168.2.255;

}

subnet 192.168.3.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.3.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Sale";
        range 192.168.1.2 192.168.3.254;

        option broadcast-address 192.168.3.255;

}

subnet 192.168.4.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.4.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Engineer";
        range 192.168.1.2 192.168.4.254;

        option broadcast-address 192.168.4.255;

}

...ใช้อยู่ครับ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ Zouchii

  • ****
  • 120
  • 0
  • เพศ: ชาย
ที่ L3 Switch

interface Vlan1 < ชื่อ Vlan
ip address 192.168.1.1  255.255.255.0 < IP Gateway ของ interface Vlan1
ip helper-address 192.168.0.1  < IP DHCP

interface Vlan2 < ชื่อ Vlan
ip address 192.168.2.1  255.255.255.0 < IP Gateway ของ interface Vlan2
ip helper-address 192.168.0.1  < IP DHCP

interface Vlan3 < ชื่อ Vlan
ip address 192.168.3.1  255.255.255.0 < IP Gateway ของ interface Vlan3
ip helper-address 192.168.0.1  < IP DHCP

interface Vlan4 < ชื่อ Vlan
ip address 192.168.4.1  255.255.255.0 < IP Gateway ของ interface Vlan4
ip helper-address 192.168.0.1  < IP DHCP


ที่ DHCP Server ไฟล์ dhcp.conf

subnet 192.168.1.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.1.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Account";
        range 192.168.1.2 192.168.1.254;

        option broadcast-address 192.168.1.255;

}

subnet 192.168.2.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.2.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Manager";
        range 192.168.1.2 192.168.2.254;

        option broadcast-address 192.168.2.255;

}

subnet 192.168.3.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.3.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Sale";
        range 192.168.1.2 192.168.3.254;

        option broadcast-address 192.168.3.255;

}

subnet 192.168.4.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.4.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Engineer";
        range 192.168.1.2 192.168.4.254;

        option broadcast-address 192.168.4.255;

}

...ใช้อยู่ครับ

สงสัยนะครับ ผมอ่านในหนังสือเห็นบอกว่าต้องทำ domain ก่อนที่จะตั้ง บน Switch L3 จริงไหม
และอีกข้อบน Server DHCP ถ้าผมใช้ Windows Server มันจะรู้ได้ไงครับว่าจะแจกอันนี้วงไหน หรือขอแค่ผมสร้าง DHCP scoop ไว้ก็พอ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ janyut

  • ***
  • 3
  • 0
  • เพศ: ชาย
พึ่งมีโอกาสได้กลับมาดู ถึงรู้ว่าตัวเองพิมพ์ผิด ตรง range ที่แจก IP

ขอแก้ไขใหม่ เผื่อมีท่านที่มาอ่านเจอ จะได้ไม่สับสน ครับ...

ที่ L3 Switch

interface Vlan1 < ชื่อ Vlan
ip address 192.168.1.1  255.255.255.0 < IP Gateway ของ interface Vlan1
ip helper-address 192.168.0.1  < IP DHCP Server

interface Vlan2 < ชื่อ Vlan
ip address 192.168.2.1  255.255.255.0 < IP Gateway ของ interface Vlan2
ip helper-address 192.168.0.1  < IP DHCP Server

interface Vlan3 < ชื่อ Vlan
ip address 192.168.3.1  255.255.255.0 < IP Gateway ของ interface Vlan3
ip helper-address 192.168.0.1  < IP DHCP Server

interface Vlan4 < ชื่อ Vlan
ip address 192.168.4.1  255.255.255.0 < IP Gateway ของ interface Vlan4
ip helper-address 192.168.0.1  < IP DHCP Server


ที่ DHCP Server ไฟล์ dhcp.conf

subnet 192.168.1.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.1.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Account";
        range 192.168.1.11 192.168.1.254; < เริ่มแจกจาก 192.168.1.11- 254

        option broadcast-address 192.168.1.255;

}

subnet 192.168.2.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.2.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Manager";
        range 192.168.2.11 192.168.2.254; < เริ่มแจกจาก 192.168.2.11- 254
        option broadcast-address 192.168.2.255;

}

subnet 192.168.3.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.3.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Sale";
        range 192.168.3.11 192.168.3.254; < เริ่มแจกจาก 192.168.3.11- 254
        option broadcast-address 192.168.3.255;

}

subnet 192.168.4.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.4.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Engineer";
        range 192.168.4.11 192.168.4.254; < เริ่มแจกจาก 192.168.4.11- 254
        option broadcast-address 192.168.4.255;

}

...ใช้อยู่ครับ

* คำสั่ง option routers  บน DHCP Server จะเป็นตัวกำหนดว่าจะให้แจกไปที่ Interface Vlan ใหน บน L3 Switch
* คำสั้ง ip helper-address บน Interface Vlan จะเป็นตัวกำหนดว่าจะให้ไปรับ IP จาก DHCP Server ตัวใหน (ซึ่งเราใช้แค่ตัวเดียวก็เพียงพอ)
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

เห็นด้วยกับคุณ Yok ครับผม

จำนวนเครื่องสำคัญมาก ทั้งณเวลานี้ และส่วนที่จะขยายเพิ่มเติมในอนาคต

IP Address SCheme จำเป็นอย่างยิ่งครับ
ต่อมาค่อย Design เรื่อง Routing ว่าจะใช้อะไร ต้อง summary หรือเปล่า ประมาณนั้นครับ

ออฟไลน์ Aunny

  • **
  • 205
  • 1
  • เพศ: ชาย
พึ่งมีโอกาสได้กลับมาดู ถึงรู้ว่าตัวเองพิมพ์ผิด ตรง range ที่แจก IP

ขอแก้ไขใหม่ เผื่อมีท่านที่มาอ่านเจอ จะได้ไม่สับสน ครับ...

ที่ L3 Switch

interface Vlan1 < ชื่อ Vlan
ip address 192.168.1.1  255.255.255.0 < IP Gateway ของ interface Vlan1
ip helper-address 192.168.0.1  < IP DHCP Server

interface Vlan2 < ชื่อ Vlan
ip address 192.168.2.1  255.255.255.0 < IP Gateway ของ interface Vlan2
ip helper-address 192.168.0.1  < IP DHCP Server

interface Vlan3 < ชื่อ Vlan
ip address 192.168.3.1  255.255.255.0 < IP Gateway ของ interface Vlan3
ip helper-address 192.168.0.1  < IP DHCP Server

interface Vlan4 < ชื่อ Vlan
ip address 192.168.4.1  255.255.255.0 < IP Gateway ของ interface Vlan4
ip helper-address 192.168.0.1  < IP DHCP Server


ที่ DHCP Server ไฟล์ dhcp.conf

subnet 192.168.1.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.1.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Account";
        range 192.168.1.11 192.168.1.254; < เริ่มแจกจาก 192.168.1.11- 254

        option broadcast-address 192.168.1.255;

}

subnet 192.168.2.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.2.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Manager";
        range 192.168.2.11 192.168.2.254; < เริ่มแจกจาก 192.168.2.11- 254
        option broadcast-address 192.168.2.255;

}

subnet 192.168.3.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.3.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Sale";
        range 192.168.3.11 192.168.3.254; < เริ่มแจกจาก 192.168.3.11- 254
        option broadcast-address 192.168.3.255;

}

subnet 192.168.4.0 netmask 255.255.255.0 {
authoritative;
# --- default gateway
        option routers                  192.168.4.1;
        option subnet-mask              255.255.255.0;

        option domain-name              "Engineer";
        range 192.168.4.11 192.168.4.254; < เริ่มแจกจาก 192.168.4.11- 254
        option broadcast-address 192.168.4.255;

}

...ใช้อยู่ครับ

* คำสั่ง option routers  บน DHCP Server จะเป็นตัวกำหนดว่าจะให้แจกไปที่ Interface Vlan ใหน บน L3 Switch
* คำสั้ง ip helper-address บน Interface Vlan จะเป็นตัวกำหนดว่าจะให้ไปรับ IP จาก DHCP Server ตัวใหน (ซึ่งเราใช้แค่ตัวเดียวก็เพียงพอ)
ต้องมีเกตเวย์ของแต่ละวงหรือครับหรืออย่างไร

ออฟไลน์ keen1234

  • *****
  • 6
  • 0
  • เพศ: ชาย
  • คนหล่อ...
ตั้งให้ เป็น Static IP คือตั้งใช้ DHCP Server แจกไอพีซ้ำเครื่องเดิม (หมายถึง สมมุติว่าเราเอาคอมมาเสียบที่นี่ ได้IP 192.168.1.5 เสียบครั้งต่อไปก็ได้เหมือนเดิม แต่ว่าเราไม่ได้ Fix IP บนคอมที่มาเสียบ เราไป Fix ที่ Server แทน) ซึ่งคุณสมบัตินี้ ถ้าใช้ในบ้าน Router บางตัวก็ทำได้
ถูกใจอย่าลืมขอบคุณน้า....

ออฟไลน์ Aunny

  • **
  • 205
  • 1
  • เพศ: ชาย
ไม่แน่ใจว่า switch srw2024Eu linksys เป็นเมเนจสวิตช์ ครับ มันทำ vlan ได้ไหมครับ
เห็นในรายละเอียดมี lan = 64 คือ วงที่มันสามารถจัดการได้ใช่ไหมครับ

แล้วการตั้งค่า เราต้องกำหนดไอพีให้ตัวสวิตช์ด้วยใช่ไหมครับอย่างเช่น

สวิตช์ ไอพี 192.168.1.1 เป็นสวิทช์ แล้วกำหนดคอมภายใต้สวิช์เป ็น 192.168.1.2-255

แล้ว DHCP มันจะเห็นเครืองภายในเองใช่รึป่าวครับ

**ตอนนี้ที่ทำงานผมมี 70 เครื่อง ไม่ได้ใช้ DHCP ฟิกไอพีเอง
แล้วก็สวิตช์ต่างๆก็ไม่ได้เซทไอพี  (เมเนจสวิทช์) ปล่อยผ่านตลอด
ผมอยากทำ vlan แต่ละแผนก ครับ แต่ยัง งงๆ ก่งก๊งมากเลยครับ
กะว่าจะเริ่มทำที่แผนกบุคคล มี 4 เครื่อง ใกล้ด้วยจะได้แก้ง่าย แต่มันต้องใช้ สวิทช์ที่ทำได้ใช่ไหมครับ

ออฟไลน์ dugdic_dugdic

  • ***
  • 4
  • 0
  • เพศ: ชาย
ใช้ IP Address 192.168.x.y     (แปลงเป็นฐานสองก็จะได้           11000000.10101000.00000000.00000000 )
Sub netmask 255.255.252.0 (แปลงเป็นฐานสองก็จะได้           11111111.11111111.11111100.00000000 )
ผมเลือก 252 เพราะเมื่อแปลงเป็นฐานสองแล้วมันได้กลุ่มเลขสวยดี

คุณเอาตัวเลขฐานสองแต่ละหลักคูณกันจะได้ Network Address   11000000.10101000.00000000.00000000
เขียนใหม่ได้ว่า                                                                                 192.168.0.0/22

มองไปเลขฐานสองกลุ่มที่ผมขีดเส้นใต้เอาไว้ คือ 00.00000000
ตรงนี้คือ Host ที่เป็นได้ทั้งหมดของคุณ แปรค่าได้ตั้งแต่ 
          00.00000000 (ยกเว้น)
          00.00000001 (ค่าแรกที่ใช้ได้ของ /22)
          00.00000010
          00.00000011
          :
          00.11111111 (ยกเว้น)
          01.00000000 (ยกเว้น)
          01.00000001
          :
          01.11111111 (ยกเว้น)
          :
          11.11111110 (ค่าสุดท้ายที่ใช้ได้ของ /22)
          11.11111111 (ยกเว้น)

ดังนั้น Host Address มีได้ตั้งแต่
          192.168.0.1 ถึง 192.168.0.254     รวม   254 Hosts (ยกเว้น  192.168.0.0 กับ 192.168.0.255)
          192.168.1.1 ถึง 192.168.1.254     รวม   254 Hosts (ยกเว้น  192.168.1.0 กับ 192.168.1.255)
          192.168.2.1 ถึง 192.168.2.254     รวม   254 Hosts (ยกเว้น  192.168.2.0 กับ 192.168.2.255)
          192.168.3.1 ถึง 192.168.3.254     รวม   254 Hosts (ยกเว้น  192.168.3.0 กับ 192.168.3.255)
                                                                     รวม 1016 Hosts เหลือพอสำหรับ 400 กว่าเครื่องของบริษัทคุณครับ

ถามถึงตรงนี้นะคับ
     00.11111111 (ยกเว้น)
     01.00000000 (ยกเว้น)
ip 192.168.0.255 และ 192.168.1.0 ทำไมถึงยกเว้นคับ มันใช้ไม่ได้ หรือไม่ควรใช้ เพราะอะไรคับ ขอความกรุณาผู้รู้ช่วยชี้แจงให้หน่อยคับ ขอบคุณมากคับ

ออฟไลน์ janyut

  • ***
  • 3
  • 0
  • เพศ: ชาย
ถามถึงตรงนี้นะคับ
     00.11111111 (ยกเว้น)
     01.00000000 (ยกเว้น)
ip 192.168.0.255 และ 192.168.1.0 ทำไมถึงยกเว้นคับ มันใช้ไม่ได้ หรือไม่ควรใช้ เพราะอะไรคับ ขอความกรุณาผู้รู้ช่วยชี้แจงให้หน่อยคับ ขอบคุณมากคับ


192.168.1.0 มันคือ Network Address
192.168.0.255 มันคือ Broadcast Address

...เว้นแต่บน Cisco ที่มีการใช้ subnet zero ...แต่ถึงยังไงก็ไม่แนะนำให้ใช้เพราะจะมีปัญหากับอุปกรณ์ ยี่ห้ออื่นๆ
เมื่อ: 10 พฤษภาคม 2011, 21:27:28
ต้องมีเกตเวย์ของแต่ละวงหรือครับหรืออย่างไร

ถูกต้องแล้วครับ
เมื่อ: 10 พฤษภาคม 2011, 21:30:55
ไม่แน่ใจว่า switch srw2024Eu linksys เป็นเมเนจสวิตช์ ครับ มันทำ vlan ได้ไหมครับ
เห็นในรายละเอียดมี lan = 64 คือ วงที่มันสามารถจัดการได้ใช่ไหมครับ

แล้วการตั้งค่า เราต้องกำหนดไอพีให้ตัวสวิตช์ด้วยใช่ไหมครับอย่างเช่น

สวิตช์ ไอพี 192.168.1.1 เป็นสวิทช์ แล้วกำหนดคอมภายใต้สวิช์เป ็น 192.168.1.2-255

แล้ว DHCP มันจะเห็นเครืองภายในเองใช่รึป่าวครับ

**ตอนนี้ที่ทำงานผมมี 70 เครื่อง ไม่ได้ใช้ DHCP ฟิกไอพีเอง
แล้วก็สวิตช์ต่างๆก็ไม่ได้เซทไอพี  (เมเนจสวิทช์) ปล่อยผ่านตลอด
ผมอยากทำ vlan แต่ละแผนก ครับ แต่ยัง งงๆ ก่งก๊งมากเลยครับ
กะว่าจะเริ่มทำที่แผนกบุคคล มี 4 เครื่อง ใกล้ด้วยจะได้แก้ง่าย แต่มันต้องใช้ สวิทช์ที่ทำได้ใช่ไหมครับ


4 เครื่องเหรอครับ...
ลองศึกษาเหตุผลุของการทำ VLAN และเทคนิคในการทำดูก่อนนะครับ
ที่สำคัญ อย่าลืมว่าแต่ละ VLANจะไม่สามารถติดต่อสื่อสารกันได้โดยตรง
ต้องอาศัย Router หรือไม่ก็  Switch Layer3
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ psake

  • **
  • 105
  • 1
Class อะไรก็ได้มา / 23   แล้วทำ Zone  DMZ , LAN , SERVER  ด้วย VLAN , ACL   ที่สวิตท์ และ Router ดีกว่า 

ณ ปัจจุบันนี้ เน้นความปลอดภัยเป็นหลัก  จะให้  IP อุปกรณ์มาปนเปื้อนกับ IP ผู้ใช้ได้เยี่ยงรั้ย     ขอแชร์ความคิดด้วยคนครับ

ออฟไลน์ dugdic_dugdic

  • ***
  • 4
  • 0
  • เพศ: ชาย

192.168.1.0 มันคือ Network Address
192.168.0.255 มันคือ Broadcast Address

...เว้นแต่บน Cisco ที่มีการใช้ subnet zero ...แต่ถึงยังไงก็ไม่แนะนำให้ใช้เพราะจะมีปัญหากับอุปกรณ์ ยี่ห้ออื่นๆ
คือเค้าบอกว่าเป็น subnet /22 น่ะคับผมเลยงงๆ

kookki

class C   มี 256 IP ครับ  เริ่มจาก 0-255   จะเห็นว่าip .0 และ .255 นั้นคือหัวและท้าย นั้นไม่สามารถใช้งานได้ครับ เพราะเป็นตัวปิดของ class นั้น

ออฟไลน์ dugdic_dugdic

  • ***
  • 4
  • 0
  • เพศ: ชาย

192.168.1.0 มันคือ Network Address
192.168.0.255 มันคือ Broadcast Address

...เว้นแต่บน Cisco ที่มีการใช้ subnet zero ...แต่ถึงยังไงก็ไม่แนะนำให้ใช้เพราะจะมีปัญหากับอุปกรณ์ ยี่ห้ออื่นๆ

เท่าที่ผมแว๊วไปหาข้อมูลมาคล้ายๆกับว่า การทำ subnet zero มันจะเป็นการเปิดใช้งาน network address แรก(ในเรื่องของการทำ vlsm) อ่าคับฃ
แล้วก็ Network Address กับ Broadcast Address มันขึ้นอยู่กับ subnet ด้วยอ่าคับ แล้วที่ผมถามถึง ip ดังกล่าวเพราะผมเห็นว่ามันเป็น /22
ซึ่งผมอ่านแต่ในตำรา ประสบการณ์ยังน้อยนัก ก็เลยเอาเองคิดว่า หากนำไปใช้งานจริงอาจมีปัญหาบางอย่าง จึงได้สอบถามดูน่ะคับ เพื่อความแน่ใจ

หากที่ผมได้ไปอ่านมาผิดพลาดประการใด ก็ขอความกรุณาช่วยแนะนำด้วยนะคับ ขอบคุณคับ

อ้างอิงข้อมูลเรื่อง subnet zero นะคับ
http://www.howtonetwork.net/public/676.cfm
http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080093f18.shtml

ออฟไลน์ Aunny

  • **
  • 205
  • 1
  • เพศ: ชาย
กรณี BroadCast Domain มีปัญหาที่ทำให้เครื่อง client ต้องจับแพคเกจมาอ่านชั่วขณะนึง
จะมีผลกระทบในตอนที่ไม่ได้แบ่ง VLAN แล้วมี broadcast มาจากหลายร้อยเครื่อง
ทำให้เป็นผลเสียต่อการใช้งานของเครื่อง Client ทุกเครื่องที่จะต้องเสียเวลามานั่งจับแพกเกจด้วยคับ
ถ้ามีสัก 80 เครื่องนี่จะมีผลเสียดังกล่าวเยอะไหมครับ

หรือว่าขึ้นอยุ่กับปัจจัยอื่น  มีอะไรบ้างครับ

kookki

ถ้าเอา ip Class C สองชุด ก็พอครับ  ทำ route  แล้วก็เซต ip pool กำหลดว่าแจกตั้งแต่ไหนถึงไหน  ก็น่าจะผ่านแล้วมั่ง

kookki

ต้องหาคนมาเกาอีกทีนะครับ ตอบความตามเข้าใจ
ถ้า subnet/24  ก็จะเป็น 255.255.255.0 = 8.8.8.0  =\24 (8 มาจาก 2ยกกำลัง8=256)
แต่ถ้าที่เขาให้มามันเป็น /22  ก็น่าจะเป็น 255.255.64.0 = 8.8.6.0 =\22 ( อันนี้ไม่แน่ใจใช่หรือเปล่า)
ต้องหาคนหันเก่ง ๆ ผมแค่พอรู้งู ๆ ปลา ๆ

ต้องหาคนมาเกาอีกทีนะครับ ตอบความตามเข้าใจ
ถ้า subnet/24  ก็จะเป็น 255.255.255.0 = 8.8.8.0  =\24 (8 มาจาก 2ยกกำลัง8=256)
แต่ถ้าที่เขาให้มามันเป็น /22  ก็น่าจะเป็น 255.255.64.0 = 8.8.6.0 =\22 ( อันนี้ไม่แน่ใจใช่หรือเปล่า)
ต้องหาคนหันเก่ง ๆ ผมแค่พอรู้งู ๆ ปลา ๆ

ไม่ใช่ 255.255.64.0 นะครับ subnet เป็นได้แค่ 128,192,224 240 248 252 254 255 ดังนั้น /22 เท่ากับ 240 ครับ นับต่อ ลงมาจาก bit ที่ 19 ลงมา 22 คำตอบก็คือ 255.255.240.0 ครับ

เข้าใจเรื่องเน็ตเวิร์คมากขึ้นครับสำหรับมือใหม่อย่างผม
ดันๆๆๆๆๆๆๆๆๆๆๆ
 O0

ออฟไลน์ Aunny

  • **
  • 205
  • 1
  • เพศ: ชาย
กระทู้นี้ ตั้งแต่ 2009 นานเหมือนกันนะเนี่ย...
ขอบคุณทุกท่านครับ
ได้ความรู้มากๆเลย

แล้วถ้าต้องการแจกสัก 2000 IP ล่ะครับทำไง เพราะต้องการติด Access Point หลายๆตำแหน่งเพื่อให้ครอบคลุมการใช้งานทั้งคณะ เพราะช่วงนี้มีเด็ก นศ. ใช้ IPhone BB IPod IPad หรืออุปกรณ์ที่ใช้ WiFi ได้มากขึ้นเรื่อยๆ ตอนนี้ 250 Class C ไม่พอแล้วครับ ( 192.168.x.1 - 192.168.x.254 ) รบกวนด้วยครับ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ B.Pharapat

  • *****
  • 4,820
  • 15
  • เพศ: ชาย
แล้วถ้าต้องการแจกสัก 2000 IP ล่ะครับทำไง เพราะต้องการติด Access Point หลายๆตำแหน่งเพื่อให้ครอบคลุมการใช้งานทั้งคณะ เพราะช่วงนี้มีเด็ก นศ. ใช้ IPhone BB IPod IPad หรืออุปกรณ์ที่ใช้ WiFi ได้มากขึ้นเรื่อยๆ ตอนนี้ 250 Class C ไม่พอแล้วครับ ( 192.168.x.1 - 192.168.x.254 ) รบกวนด้วยครับ

2000 ip นี่ ต้องแบ่ง vlan แล้วล่ะครับ ว่า vlan ไหน ใช้ กับ user กลุ่มไหน

2000 ip นี่ ต้องแบ่ง vlan แล้วล่ะครับ ว่า vlan ไหน ใช้ กับ user กลุ่มไหน
ถ้าจะขอตอบว่า user กลุ่มเดียวล่ะครับ เพราะว่า นศ. จะมีการเดินเรียนไปอีกตึกนึง ซึ่ง นศ.นี้จะย้ายไปเรื่อยๆ แต่เราต้อง support wifi ใช้สามารถใช้งานได้ตลอดน่ะครับ
ขอบคุณสำหรับคำแนะนำครับ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ akephop

  • ****
  • 54
  • 1
  • TH@min Membership
ถ้าจะขอตอบว่า user กลุ่มเดียวล่ะครับ เพราะว่า นศ. จะมีการเดินเรียนไปอีกตึกนึง ซึ่ง นศ.นี้จะย้ายไปเรื่อยๆ แต่เราต้อง support wifi ใช้สามารถใช้งานได้ตลอดน่ะครับ
ขอบคุณสำหรับคำแนะนำครับ


   ถ้ามี Output LAN แค่ใบเดียว เช่น

   IP lan = 192.168.1.1  ก็สามารถแจก ไป เช่น 192.168.1.2 ถึง 192.168.254.254  ก็ได้ถ้าใช้ Subnet 255.255.0.0

   ก็สามารถใช้งานได้ แต่ BC จะเยอะมาก อันตราย  แต่ถ้าทำแบบ มี Output LAN หลาย ใบ ละ เช่น

  IP lan 1 = 192.168.1.1   <  แจก ช่วง ip 192.168.1.2 - 192.168.1.254 >
  IP lan 2 = 192.168.2.1   <  แจก ช่วง ip 192.168.2.2 - 192.168.2.254 >

  ไปเรือยๆตามจำนวนแลน หรือ

  มี Output LAN หลาย ตัว โดยใช้ VLAN มาช่วย
 เช่น เราไปซื้อ อุปกรณ์ Switch  L2 หรือ L3 ( ใช้ แค่ L2 ก็พอถ้าไม่ต้องการ ส่วนของ QoS ทำ VLAN อย่างเดียว )

 แล้ว ทำ Trunk ไปยัง eth output ที่ ตั้งเอาไว้ เช่น  eth0 ip 192.168.1.1

 จากนั้น สร้าง Vlan ให้กับ eth0 อาจจะเป็น

 eth0.11    จัดการ ทำ NAT ให้ออกวงนี้ พร้อมทั้ง ตั้ง ip ให้ ตัวนี้เป็น  192.168.11.1 แล้ว แจก 192.168.11.2-192.168.11.254
 eth0.12    จัดการ ทำ NAT ให้ออกวงนี้ พร้อมทั้ง ตั้ง ip ให้ ตัวนี้เป็น  192.168.12.1 แล้ว แจก 192.168.12.2-192.168.12.254
 eth0.13    จัดการ ทำ NAT ให้ออกวงนี้ พร้อมทั้ง ตั้ง ip ให้ ตัวนี้เป็น  192.168.13.1 แล้ว แจก 192.168.13.2-192.168.12.254
 eth0.14     จัดการ ทำ NAT ให้ออกวงนี้ พร้อมทั้ง ตั้ง ip ให้ ตัวนี้เป็น  192.168.14.1 แล้ว แจก 192.168.14.2-192.168.12.254

 ก็จะได้ 254 x 4 ละ  ได้ 1016 เครื่องละ  + BC ก็จะไม่เยอะ เท่า แบบแรก ครับ  ต้องการ ถึง 2000 เครื่องก็จัดไปอีก 4 Rank  ครับ ก็จะได้ละ เนอะ
 ประมาณนี้ก็ได้ครับ หรือแบบแรก ก็เสี่ยงกับ ปริมาณ ข้อมูลที่ไหล ผ่าน ตลอดเวลา
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ yatmon2

  • ***
  • 48
  • 0
ขอบพระคุณทุกคำถาม และทุกคำตอบ ที่ทำให้ Admin มือใหม่อย่างผมได้ต่อยอดความรู้เรื่องการจัดระบบได้มาอีกระดับ

เพื่อจะได้นำไปพิจารณา ใช้กับองค์กรที่ผมดูแลอยู่อีกทอดหนึ่ง

นับเป็นแหล่งความรู้ที่ดีที่สุดในตอนนี้ เลยก็ว่าได้ ขอบคุณครับสำหรับ www.thaiadmin.org

ที่ได้เป็นแห่ลงแชร์ประสบการณ์ และความรู้ต่างๆๆ ขอบคุณจากใจจริงๆครับ

dosdiosas2209

ได้ความรู้เพิ่มเติมมากขึ้น เพราะสนใจในด้านนี้มาก ๆๆ ขอบคุณค่ะ

มือใหม่ขอถามด้วยครับ
รร.เหมือนกัน ใช้เน็ต30เมก ประมาณ 600 เครื่อง
ทำ authen เก็บ log ตาม พรบ ใช้ dhcp 3 ตัว
แจก ip
172.16.0.1
172.16.2.1
172.16.4.1
ใช้ l2 ธรรมดาในแต่ละตึก
รับเน็ตจาก adsl มีการจำกัดแบนวิดให้แต่ละชั้นเรียนใช้ไม่เท่ากัน
ตอนติดตั้งใหม่ระบบจะล่มบ่อยและช้ามาก
สาเหตุที่พบ
- มีaccespoint หลายตัว แจก ip เข้ามาในระบบ
-สาย lan ต่อวนลูปกัน

หลังจากแก้ไขแล้ว ดีขึ้นในระดับหนึ่ง


คำถาม
ถ้าให้ adsl แจก
192.168.0.1-192.168.3.254
255.255.252.0
192.168.0.1

แทนการใช้ dhcp server 3 ตัว
แบบว่าให้แจกทั้ง รร เลย ไม่ authen ไม่ กำหนด แบนวิด จะได้ไหม
ใช้ในกรณี server พัง
แล้วทุก ip จะ ping เห็นกันไหม

จะลองเล่นๆช่วงปิดเทอม

มือใหม่ขอถามด้วยครับ
รร.เหมือนกัน ใช้เน็ต30เมก ประมาณ 600 เครื่อง
ทำ authen เก็บ log ตาม พรบ ใช้ dhcp 3 ตัว
แจก ip
172.16.0.1
172.16.2.1
172.16.4.1
ใช้ l2 ธรรมดาในแต่ละตึก
รับเน็ตจาก adsl มีการจำกัดแบนวิดให้แต่ละชั้นเรียนใช้ไม่เท่ากัน
ตอนติดตั้งใหม่ระบบจะล่มบ่อยและช้ามาก
สาเหตุที่พบ
- มีaccespoint หลายตัว แจก ip เข้ามาในระบบ
-สาย lan ต่อวนลูปกัน

หลังจากแก้ไขแล้ว ดีขึ้นในระดับหนึ่ง


คำถาม
ถ้าให้ adsl แจก
192.168.0.1-192.168.3.254
255.255.252.0
192.168.0.1

แทนการใช้ dhcp server 3 ตัว
แบบว่าให้แจกทั้ง รร เลย ไม่ authen ไม่ กำหนด แบนวิด จะได้ไหม
ใช้ในกรณี server พัง
แล้วทุก ip จะ ping เห็นกันไหม

จะลองเล่นๆช่วงปิดเทอม


กำลังทำของโรงเรียนอยู่เหมือนกันครับ

เอ่อ ผมขอถามบ้างซักนิดนะครับ พอดีเป็นแค่ Support ไม่ค่อยได้รู้เรื่องอะไรมากนักแต่หัวหน้าให้หาข้อมูลน่ะครับ

ถ้าตอนนี้ผมมี user 80 เครื่อง กำลังจะเพิ่ม office อีกส่วนนึง แต่อยู่คนละตึกคิดว่าคงเพิ่มไม่เยอะครับ ^^"
ตอนนี้มี L#3 Switch อยู่ตัวนึงครับแจก 192.168.0.0 กับ 192.168.1.0
ทีนี้ถ้าเราอยากได้ 192.168.2.0 เนี่ย ผมต้องซื้อ L#3 อีกตัวไปไว้ที่ตึกใหม่ รึเปล่าครับ? แล้วลากLANข้ามตึก มาต่อที่ L#3 ตัวแรกใช่มั้ยเอ่ย?
แค่อยากได้ idea ความรู้จากท่านทั้งหลายน่ะครับ ว่าพอจะมี option อะไรบ้าง ^^" ขอความกรุณาด้วยครับ  :)

ออฟไลน์ :: นักโทษประหาร ::

  • *****
  • 1,158
  • 11
  • เพศ: ชาย
  • http://www.itmanage.info
หา switch L3 เช่น cisco หรือ ยี่ห้อไหนก็ได้ที่เราถนัด Config ในส่วนของ VLAN , Trunking , Interfase VLAN,  Routing และ DHCP แต่หละ Group Network ของ VLAN  ครับ  :)


รักที่จะเรียนรู้ คิดเมื่อมีสิ่งที่เรียกว่าอุปสรรค ฉลาดเมื่อเห็นว่าเหตุผลกับแนวทางตรงกัน เฉลียวเมื่อเห็นว่ามีสิ่งที่เราคิดว่าเกิดจากประสบการณ์  (ถามผู้มีประสบการ์มากกว่าถามผู้รู้)

หา switch L3 เช่น cisco หรือ ยี่ห้อไหนก็ได้ที่เราถนัด Config ในส่วนของ VLAN , Trunking , Interfase VLAN,  Routing และ DHCP แต่หละ Group Network ของ VLAN  ครับ  :)

อ่อ ตอนนี้ผมใช้ของ 3Com อยู่น่ะครับ หัวหน้าอยากทราบ command set ให้เป็น 192.168.2.0 ด้วย T_T เด๋วคงต้องไปขุดๆๆก่อน ถ้าท่านใดทราบขอความกรุณาบอกด้วยนะครับ

ออฟไลน์ rujipars

  • ***
  • 394
  • 3
ถ้าว่าตามความจำเป็นขั้นต่ำแล้ว  L3 switch  ใช้ตัวเดียวก็พอ   ถ้ามีอีกตึกก็แค่อนุญาตให้ VLAN ของตึกนั้นวิ่งข้ามตึกมาให้ถึง L3 switch ก็สามารถ route ข้าม VLAN ได้แล้วครับ

แต่ถ้าจะมีไว้อีกตัวเพื่อความอุ่นใจเผื่อเสียจะได้มีทดแทนได้ทันที  แบบนั้นก็ได้ครับ

เอ้อ  ข้างบนบอกไว้ว่า /22  = 255.255.240.0   จริงแล้วต้องเป็น 255.255.252.0 นะครับ  และที่นับจาก 19 มา 22 นั่นก็มั่วด้วย

Class ของ network ดูจาก byte (octet) แรกของ IP address  เช่น  10.1.2.0/24   ยังไงก็เป็นคลาส A  (octet แรกมีค่า = 10)    ถ้ามองแบบ classfull  มันก็คือ subnet ของ 10.0.0.0/8  ที่ยืม bit มาทำ subnet mask เสีย 16 บิต   หรือถ้ามองแบบ classless มันก็คือ prefix  ที่มีหมายเลข network  24 bit แค่นั้น

เจอเป็นประจำเรื่องการระบุคลาสของ address ตาม subnet mask (ซึ่งเป็นความเข้าใจที่ผิด) แต่ก็เออๆ ออๆ ไป  ขี้เกียจถกเถียงยืดยาว

บริการ netmark ครับ

Supernet

Netmask:   255.255.254.0 = 23    11111111.11111111.1111111 0.00000000
Wildcard:  0.0.1.255             00000000.00000000.0000000 1.11111111

Network:   192.168.0.0/23        11000000.10101000.0000000 0.00000000 (Class C)
Broadcast: 192.168.1.255         11000000.10101000.0000000 1.11111111
HostMin:   192.168.0.1           11000000.10101000.0000000 0.00000001
HostMax:   192.168.1.254         11000000.10101000.0000000 1.11111110
Hosts/Net: 510                   (Private Internet)
--
สังคมแห่งการแบ่งปัน



ออฟไลน์ akephop

  • ****
  • 54
  • 1
  • TH@min Membership
  ไปโหลดโปรแกรม มาช่วย เหอะ  จะได้ง่ายๆๆ หน่อย เช่นพวก  netcalc หรือบน ลีนุกซ์ก็มีงับ อันไหนใช้สบาย ใช้ง่าย ใช้ไปก่อน เหอะอย่าคิดมากแล้ว ค่อยๆพัฒนา ให้ตรงกับ เครือข่ายของท่านดีที่สุด

  ( การพัฒนา คือ การปรับแต่งประยุกต์เพื่อให้เกิดประโชยน์สูงสุด )
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ Zouchii

  • ****
  • 120
  • 0
  • เพศ: ชาย
มือใหม่ขอถามด้วยครับ
รร.เหมือนกัน ใช้เน็ต30เมก ประมาณ 600 เครื่อง
ทำ authen เก็บ log ตาม พรบ ใช้ dhcp 3 ตัว
แจก ip
172.16.0.1
172.16.2.1
172.16.4.1
ใช้ l2 ธรรมดาในแต่ละตึก
รับเน็ตจาก adsl มีการจำกัดแบนวิดให้แต่ละชั้นเรียนใช้ไม่เท่ากัน
ตอนติดตั้งใหม่ระบบจะล่มบ่อยและช้ามาก
สาเหตุที่พบ
- มีaccespoint หลายตัว แจก ip เข้ามาในระบบ
-สาย lan ต่อวนลูปกัน

หลังจากแก้ไขแล้ว ดีขึ้นในระดับหนึ่ง


คำถาม
ถ้าให้ adsl แจก
192.168.0.1-192.168.3.254
255.255.252.0
192.168.0.1

แทนการใช้ dhcp server 3 ตัว
แบบว่าให้แจกทั้ง รร เลย ไม่ authen ไม่ กำหนด แบนวิด จะได้ไหม
ใช้ในกรณี server พัง
แล้วทุก ip จะ ping เห็นกันไหม

จะลองเล่นๆช่วงปิดเทอม


ผมไม่มั่นใจนะครับ ว่า ADSL Router ทำได้แบบนั้นไหม ส่วนใหญ่ตั้งได้แต่ Range กับ Subnet เดียว (รุ่นเก่า)
แต่ถ้าให้ผมแนะนำให้ DHCP Server ตัวเดียว แต่แจกได้ 3 วง
แล้วให้ L3 Switch มาจัดการเรื่อง Vlan อีกทีครับ
รู้สึกว่าจะเวิร์คกว่านะครับ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ Zouchii

  • ****
  • 120
  • 0
  • เพศ: ชาย
เอ่อ ผมขอถามบ้างซักนิดนะครับ พอดีเป็นแค่ Support ไม่ค่อยได้รู้เรื่องอะไรมากนักแต่หัวหน้าให้หาข้อมูลน่ะครับ

ถ้าตอนนี้ผมมี user 80 เครื่อง กำลังจะเพิ่ม office อีกส่วนนึง แต่อยู่คนละตึกคิดว่าคงเพิ่มไม่เยอะครับ ^^"
ตอนนี้มี L#3 Switch อยู่ตัวนึงครับแจก 192.168.0.0 กับ 192.168.1.0
ทีนี้ถ้าเราอยากได้ 192.168.2.0 เนี่ย ผมต้องซื้อ L#3 อีกตัวไปไว้ที่ตึกใหม่ รึเปล่าครับ? แล้วลากLANข้ามตึก มาต่อที่ L#3 ตัวแรกใช่มั้ยเอ่ย?
แค่อยากได้ idea ความรู้จากท่านทั้งหลายน่ะครับ ว่าพอจะมี option อะไรบ้าง ^^" ขอความกรุณาด้วยครับ  :)


ไม่ต้องครับ
ตั้ง DHCP มาอีกชุดนึงแล้ว ตั้งค่าให้ L3 วิ่งมาที่ DHCP ตัวนี้ เพื่อแจกค่า วงนี้ครับ
(ตามความเข้าใจผมนะครับ)
แล้วใช้ L2 ที่รับ L3 ได้ประมาณนั้นครับ
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

 ปัญหามาอีกแล้ว
รร.แห่งหนึ่ง

ทำ authen เก็บ log ตาม พรบ ใช้ dhcp 3 ตัว ubuntu
แจก ip
172.16.0.1
172.16.2.1
172.16.4.1
ใช้ l2 ธรรมดาในแต่ละตึก
รับเน็ตจาก adsl มีการจำกัดแบนวิดให้แต่ละชั้นเรียนใช้ไม่เท่ากัน
internet 30 mbps
อาจารย์ บอกมันช้า แบบวิทด์ ไม่พอหรือป่าว

ชี้แนะด้วยครับ

ถ้าจะทำ DHCP ผ่าน Internet หล่ะครับผม พอจะทำได้ไหมครับ
รองรับทั่วประเทศอ่าครับ

ออฟไลน์ jokeryamer

  • *
  • 11
  • 0
  • เพศ: ชาย
ช่วยตอบอีกคนนะครับ

มี client ตั้ง 400 ผมว่าถ้าใช้ ip วงเดิม คงต้องแบ่งอย่างน้อย 5 vlan
- 192.168.0.xxx > for server
- 192.168.1.xxx > for 1-100
- 192.168.2.xxx > for 101-200
- 192.168.3.xxx > for 201-300
- 192.168.4.xxx > for 301-400

แต่ถ้ามีปัจจัยอื่นๆ ประกอบ อาจจะต้องพิจารณาเพิ่มเติมครับ เช่น มีหลายชั้น มีหลายตึก เป็นต้น แบ่งเป็นจำนวนอาคาร หรือตามชั้นที่อยู่ ก็ดีนะครับ แล้วแต่ว่าจะออกแบบอย่างไร...^^
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

ออฟไลน์ uhejin

  • ***
  • 3
  • 0
ติดปัญหา จาก DHCP SERVER ทำ SCOPE แจก ไอพีตาม Vlan แล้ว แต่ทำไงจาก SW cisco SF300-28 small bussiness ใครเคย set รบกวนขอความช่วยเหลือหน่อยครับ
ขอบคุณครับ

ออฟไลน์ uhejin

  • ***
  • 3
  • 0
ติดปัญหา จาก DHCP SERVER ทำ SCOPE แจก ไอพีตาม Vlan แล้ว แต่ทำไงจาก SW cisco SF300-28 small bussiness ก็แจกไอพีไม่ครบทุก Vlan ตามที่ config ใครเคย set รบกวนขอความช่วยเหลือหน่อยครับ
ขอบคุณครับ


Pawding

192.168.0.0/22
/22   255.255.254.0 = 512-2 =510  เครือง
/21   255.255.252.0 = 1024-2 = 1022 เครื่อง

Pawding

ลืมบอกไอพี 192.168.0.1   ถีง    192.168.3.254

SW cisco SF300-28 small bussiness ก็แจก IP เองได้นะครับ

อยู่ใน Junction ไหนก็แจกใน VLAN ที่มี Port สมาชิก Access เยอะๆไปก็ได้นี่ครับ
ไม่จำเป็นต้องใช้ SERVER แจกเสมอไป
กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย

บุคคลทั่วไป

ขั้นที่ 1.
วางแผนง่ายๆ ก่อน
แบ่ง vlan

ตามแผนก เช่น vlan 10 hr, vlan 20 AC,vlan 30 IT เหล่านี้สำหรับ PCs ทั้งหมด
ตามหน้าที่ เช่น vlan 40 CCTV ป้องกัน traffic ไม่ต้องไปยุ่งกับชาวบ้าน
แบ่งตามลักษณะการอุปกรณ์ไอที เช่น notebook,มือถือ โดยให้เป็นหนึ่ง vlan 50 อาจจะตัังชื่อว่า WiFi
เพิ่มอีก 2 vlan
vlan 60 server สำหรับ Server ทั้งหมด
vlan 70 network สำหรับ network เช่น switch l3,firewall

ขั้นที่ 2
วาดรูปง่ายๆ เป็นสี่เหลี่ยมแยกตาม vlan
sw ที่จะแบ่ง vlan ก็เป็น L3

ขั้นที่ 3
เริ่ม config L3
กำหนด vlan
กำหนด ip
กำหนด port ที่จะมาเป็น member (tag หรือ  untag)
กำหนด ip helper คือ ip ของ dhcp server
ทำให้ครบทุก vlan ที่ได้ออกแบบไว้

ขั้นที่ 4
สมมุติว่าทำเครื่อง server และติตตั้ง dhcp server เรียบร้อยแล้ว
config dhcp ให้แต่ละ vlan ทำที่ server
โดยกำหนด scop เช่น start 192.168.10.1  end 192.168.10.100 ,DNS เอาเป็น ip ของ dhcp server ก็ได้ (ถ้ามีไม่หลายตัว) ทำทีละ vlan จนครบตามที่ได้ออกแบบไว้

หรือ fix ip ตามต้องการ



ผมไม่ใช่มือใหม่นะครับ แต่บอกเลยว่าไม่มีความรู้เลย เรียกได้ว่าเป็น support

สิ่งที่อยากรู้คือ

1.ถ้าเเบ่ง วง lan ตามตัวอย่าง ไวรัสจะไม่ข้ามวงได้อย่างไร เนื่องจากมีการแชร์ข้อมูลระหว่างแผนก
2. ตามที่ได้อ่าน 192.168.1.xx กับ 192.168.2.xx และ อื่นๆ นับเป็นวงเดี๋ยวกันได้อย่าไร ผมงงจริงๆ
3. เรื่อง class b มันต่างกับ class อื่นๆ อย่างไร

ขอโทษด้วยที่ถามโง่ๆ เพราะผมไม่เคยเข้าใจเรื่อง class เลย ส่วนมากจะไปต่องานจาก it คน เก่า เลยไม่ได้คิดเรื่อง network เลย

ขอบคุณทุกท่านที่สั่งสอน

ออฟไลน์ khanclub

  • *
  • 588
  • 0
  • เพศ: ชาย
  • รอยยิ้มไม่กินน้ำมัน
    • http://auto4t.spaces.live.com/
เอา infrastructure  มานั่งคุยกัน ก่อน ดีกว่าใหมครับ
<b>กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย</b>

ออฟไลน์ alake

  • *****
  • 5
  • 0
 ;D อ่านมาตั้งแต่ต้นกระทู้เลย ได้ความรู้แบบงงๆ แต่ยังติดตามอยู่นะครับ ^-^

เอา infrastructure  มานั่งคุยกัน ก่อน ดีกว่าใหมครับ

ถ้าอยากศึกษาพื้นฐานเรื่อง infrastructure นี้ควรจะเริ่มต้นที่ไหน ยังไงครับ
รบกวนแนะนำเป็นไกด์ไลน์หน่อยครับ
จักเป็นพระคุณอย่างสูง

ออฟไลน์ lusifer

  • *****
  • 2,987
  • 11
  • เพศ: ชาย
  • Create new planet
ผมไม่ใช่มือใหม่นะครับ แต่บอกเลยว่าไม่มีความรู้เลย เรียกได้ว่าเป็น support

สิ่งที่อยากรู้คือ

1.ถ้าเเบ่ง วง lan ตามตัวอย่าง ไวรัสจะไม่ข้ามวงได้อย่างไร เนื่องจากมีการแชร์ข้อมูลระหว่างแผนก
2. ตามที่ได้อ่าน 192.168.1.xx กับ 192.168.2.xx และ อื่นๆ นับเป็นวงเดี๋ยวกันได้อย่าไร ผมงงจริงๆ
3. เรื่อง class b มันต่างกับ class อื่นๆ อย่างไร

ขอโทษด้วยที่ถามโง่ๆ เพราะผมไม่เคยเข้าใจเรื่อง class เลย ส่วนมากจะไปต่องานจาก it คน เก่า เลยไม่ได้คิดเรื่อง network เลย

ขอบคุณทุกท่านที่สั่งสอน

สิ่งที่อยากรู้คือ

1.ถ้าเเบ่ง วง lan ตามตัวอย่าง ไวรัสจะไม่ข้ามวงได้อย่างไร เนื่องจากมีการแชร์ข้อมูลระหว่างแผนก
: ถ้าไม่มีการป้องกันที่ดีพอ  virus เลื่่อยไปทุก network ที่มันเจอ ครับ จากนั้น IT เตรียมตัวเก็บของ

2. ตามที่ได้อ่าน 192.168.1.xx กับ 192.168.2.xx และ อื่นๆ นับเป็นวงเดี๋ยวกันได้อย่าไร ผมงงจริงๆ
: การแบ่ง Vlan มรจุดประสงค์หลายด้าน เช่น แยก แผนก เพื่่อดูแล , การแยก Server network , Client network
http://panudech.rmutl.ac.th/CPN/Lab06.pdf

3. เรื่อง class b มันต่างกับ class อื่นๆ อย่างไร
: IP Class B ต่างอย่างไร ขอให้อ่านนี้ครับ http://ipadressa.weebly.com/3585363436193649361036563591-class.html

ขอโทษด้วยที่ถามโง่ๆ เพราะผมไม่เคยเข้าใจเรื่อง class เลย ส่วนมากจะไปต่องานจาก it คน เก่า เลยไม่ได้คิดเรื่อง network เลย
: ไม่เป็นไรครับ ทุกคนย่อมมีก้าวแรกเสมอ อยู่ที่ ท่านจะกล้าก้าวขาเดินหรือไม่
<b>กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย</b>

ออฟไลน์ lusifer

  • *****
  • 2,987
  • 11
  • เพศ: ชาย
  • Create new planet
ถ้าอยากศึกษาพื้นฐานเรื่อง infrastructure นี้ควรจะเริ่มต้นที่ไหน ยังไงครับ
รบกวนแนะนำเป็นไกด์ไลน์หน่อยครับ
จักเป็นพระคุณอย่างสูง
สวัสดีครับ

ควรเริ่มต้นจากก้าวเด็กในการค้นหาข้อมูล ครับ
infrastructure คืออะไร
infrastructure ประกอบด้วยอะไรบ้าง
server + router + switch + firewall + modem + IP Phone + IPBX
PC layout
เมื่อ ท่านมองเห็นแสงสว่าง แล้วว่า Infrastructure ของท่่านเองมีอะไีบ้าง และเชื่อมต่อแบบไหน เมื่ิเกืดปัญหาใดๆ ท่านสามารถแก้ไขได้รวดเร็วและตรงจุด

<b>กลุ่มผู้ดูแลระบบแห่งประเทศไทย ขอระงับการใช้ลายเซ็นต์รูปภาพ
อนุญาตให้ใช้ได้เพียง ลายเซ็นต์ที่เป็นข้อความ
จึงประกาศมาเพื่อขอความร่วมมือ จากสมาชิกทุกๆ ท่าน
ในนาม กลุ่มผู้ดูแลระบบแห่งประเทศไทย</b>

ptanawit

เป็นผมจะ fix ip ครับ แยกวงแยกแผนก ลด broadcast . วันไหน DHCP server ตายนี้นรกชัดๆ ให้ DHCP แจกเฉพาะพวก wifi ครับ








้http://www.pn-networks.com

ptanawit

เป็นผมจะ fix ip แล้วแบ่งหลายๆ วงเพื่่อลดการ broadcast .







http://www.pn-networks.com

ออฟไลน์ ตาน้อยคุง

  • ***
  • 400
  • 5
  • เพศ: ชาย
  • ผมไม่หล่อ... แต่ผมจน
เด๋วนะครับ ออกแบบให้อย่างสวย... แต่อุปกรณ์ที่มีไม่รองรับก็จบครับ
400 เครื่องนี่ก็เยอะนะครับ ดูคนเดียวหรือดูกี่คน
จะจัด 1 Network Address เลยมันก็ง่ายดี จบเร็ว

แต่ควรคำนึงถึงพวกนี้ด้วย ว่าใน System เรามีหรือไม่หรือจำเป็นจะต้องมีหรือไม่ในอนาคต เอา VLAN เข้ามาช่วยชีวิตจะง่ายขึ้นเยอะครับ
Server Segment
DMZ Segment ?
Client Segment
Voice Segment
Management ?

ปล. กระทู้ปี 2009 !!!
Do it better with Linux
My Server : FreeBSD 8.2 , Ubuntu 10.10
My Desktop : Ubuntu 10.04 , Windows XP (Sp3) x64, Windows 7 Ultimate